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Introducing DanceForms 1.0: Software for Visualizing
and Chronicling Choreography

• These Exercises are designed to teach you how to use DanceForms character motion
software to visualize and record dance sequences on your personal computer.

• They take you through a series of Exercises designed to help you explore some basic
animation concepts and techniques you will need to analyze, model and simulate
human movement.

Who are the Exercises for?
These Exercises are geared to dance teachers, choreographers and enthusiasts.

• Some of you might want to learn how to document your own classroom combinations
or choreography. You will learn how to use customized palettes and animations to
build dance sequences and repertoire.
This use of DanceForms can be thought of as animated dance notation.1 It requires an
ability to break down the component parts of each position and step, and may help
you sharpen your eye and hone valuable pedagogical skills.

• Some of you might want to provide clear visual representations of dance movements,
as an aid to the teaching or learning of dance technique.2

You will learn how to use the animations to:
1. Illustrate technical terms, e.g., What is a plié, sauté, etc.?

What is the difference between a battement jeté and a battement glissé?
2. Illustrate the sequence of joint actions involved in dance technique, e.g.,

How does the weight shift in slow versus fast brushes to side?
Does a pas de chat take off from two feet or one?

This requires some knowledge of human anatomy and biomechanical principles,
coupled with an understanding of dance aesthetics. Ballet, for example, is about
illusion. The Exercises help define what dancers do to create the illusion of an easy
defiance of gravity. For example, to create the illusion of lightness in jumping, the
dancer does a quick push-off, rearranges the limbs to suggest a suspension at the
height, and then does a slow, cushioned landing “through the feet”.

• Some of you might want to animate other forms of human movement, like other
social and theatrical dance forms or dance fitness exercises.
You will learn basic animation principles that can be applied to a range of contexts.

                                                
1 For information on the two major systems used in the dance world today, visit websites for Benesh
notation http://www.rad.org.uk and Labanotation http://www.dancenotation.org.
2 For an animated dictionary of classical ballet positions and movements, see the Ballet Moves II CD.
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Basic Animation Principles
• These DanceForms Exercises and animations balance visual clarity against

anatomical and biomechanical correctness. They aim to represent the structure of
movement, i.e., what the choreographer intends the viewer to see, or what the dancer
intends to do. The animations do not claim to provide a realistic record of
performance, a goal better suited to film or video, or to motion capture animation.

• Keyframed animation, the method described in this manual, consists of a series of
frames where the animator defines body shape, location, etc. This classical animation
technique produces simulations that are more idealized and abstract than motion
capture, which produces files that are more realistic but denser and harder to manage.
When you start your animation, be clear about what level of abstraction you want.

• To simplify your animation file and make it manageable to work with, you should
observe the following guidelines:

1. Compromise between compactness and completeness.
There is a continuum between simplicity and complexity. Your animations should be
complete enough to suggest the elements you want to illustrate, but compact enough
to make editing and manipulating them as easy as possible.

2. Use the lowest frame rate needed.
The frame rate is the number of frames displayed each second. DanceForms uses a
default frame rate of three frames per second (fps). Professional animations are about
30 fps. In general, the slower the movement tempo (the lower the rate of change in
body positions), the lower the frame rate. If you start with a low frame rate, your file
will be shorter, i.e., contain fewer frames for a given time duration. You can always
increase the frame rate later, if you find you need finer increments.

3. Use the fewest keyframes needed.
A keyframe is a frame that stores information you set about the dancer’s position
(keyshape), location, facing, etc. at one point in time. Create keyframes for the start
and end of each basic movement unit (e.g., the opposite extremes of joint action),
then find the fewest keyframes needed to define any detours you want. This produces
a “clean” animation with fewer unexpected detours.

4. Work from the general to the specific.
Start by mapping out the key moments in your sequence, then “fill in the blanks”
between key positions. Find the underlying structure or pattern. If a position or
sequence is to be repeated or varied, start with the basic version. Make sure you get it
right before copying it into other parts of the animation. Then you can easily vary
elements like direction, timing, speed, etc.
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How to Use this Guide

You are now ready to try your hand at chronicling choreography with DanceForms. It’s
best to start by doing the first six Exercises in order to get an overview (Part A).

If you are eager to begin creating body positions in the DanceForms STUDIO, start with
Part A Exercise 1, then skip to Part B and begin doing Exercises 7-10. But be
forewarned: Part B is the most difficult section. It requires a good ability to break down
positions and analyze movements, as well as to master a new set of DanceForms features.
No need to do this whole section in order. Rather you should use it as a reference for
creating body positions and palettes, or for refining those that come with Ballet Moves
and Modern Dance Moves.

If you want to learn how to use the Ballet Moves and Modern Dance Moves Dictionaries,
you can go right from Part A into Part C, and get started visualizing your own
enchaînements and combinations.

If you encounter problems or if you come up with your own solutions that you would like
to share, you can post comments on the DanceForms Subscriber List, a free service.

To subscribe, go to http://list.web.ca/lists/listinfo/danceforms-l.

Have fun!
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PART A:
Entering the DanceForms World

These Exercises introduce basic DanceForms features
and explain how to use customized palettes

to create short dance sequences

Exercise 1 Exploring the Virtual Dance Space:
Introducing the STAGE, STUDIO and SCORE

Exercise 2 Creating a Port de Bras:
Exploring Sequence and Timing

Exercise 3 Creating a Jump Combination:
Exploring Altitude

Exercise 4 Creating a Turn:
Exploring Facing

Exercise 5 Creating a Battement Brush:
Exploring “Tweening” and Refining Body Positions

Exercise 6 Creating a Walk:
Exploring Location, Paths, Snap
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Exercise 1. Exploring the Virtual Dance Space:
Introducing the STAGE, STUDIO and SCORE

Choreographers create dance in many ways and from many different motivations. We
may begin by expressing an inner impulse or idea. Or we may respond to a piece of
music that moves us. Whatever the motivation, the result is movement – a change in body
position in space through time.

The medium of dance is human movement, the instrument is the human body, and the
basic unit is a dance phrase. We can think of a dance phrase as a unique set of body
configurations arranged in a specific sequence. This series of two or more positions is
somehow connected or phrased through time. The nature of these configurations and
transitions gives the phrase its unique spatial and dynamic qualities. A basic dance phrase
may be further defined or set in relation to the performance space and to other dancers.

It might be helpful to differentiate between two uses of the word “position”. In
DanceForms we use the term position to refer to a specific arrangement of body parts in
relation to one another. For the dancer’s placement in the performance area we use the
term location.

To enter the DanceForms world, we look through special purpose “windows”. The
choreographer creates body positions in the STUDIO by defining each body keyshape.
The choreographer then orders the sequence of body positions or keyshapes by adding
them to the SCORE, much the same as music notes are sequenced from left to right in an
orchestral score. Finally, the choreographer places the dancer in relation to the
performance space in the STAGE. This is where he or she sets the dancer’s placement
upstage or downstage and stage right or left, and on or off the floor. It is also where the
choreographer sets the dancer’s facing angle, e.g., straight to the audience (en face), to
the wings (de côté), or to the corners (croisé, effacé, écarté, etc.). DanceForms
automatically links the keyshapes through time to give continuous transitions.

To see the final DanceForms dance, the choreographer watches the PERFORMANCE.3

The PERFORMANCE brings all the elements together, displayed by a fleshed-out virtual
dancer or dancers. The choreographer can watch the dance from any perspective – front
(from the audience view), back (from upstage), side (from the wings), top (from above),
etc. – and at any speed.

                                                
3 In Life Forms, the STUDIO is called the FIGURE EDITOR window, the SCORE is called the
TIMELINE window, and the PERFORMANCE is called the RENDERED window.
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REMEMBER, IN DANCEFORMS YOU ARE THE CHOREOGRAPHER LOOKING
FROM OUTSIDE AT YOUR DANCE AS YOU CREATE IT.

1. Double click on “Exercise1.lfa” to launch DanceForms 1.0. This is what you see.
TIP: Views vary from Mac to Win4 and from monitor to monitor. To see all
windows, place your cursor on the Window menu item at the top of the screen, press
and hold down the mouse button, then drag downward and release it on Arrange.

 1.1 The STAGE window, top left, shows the DanceForms dancer standing on the
stage. This window is where you move the dancer around the performance space.

 1.2 The STUDIO window, top right, shows the DanceForms dancer with her body
parts outlined in colours. This is where you change her body position (head, torso, limbs).

 1.3 The SCORE window appears along the bottom of the screen. It shows a series
of keyshapes (miniature body positions) in sequence, much like a musical score.

 1.4 The PANEL, shown here at the bottom left, allows you to watch combinations
using buttons similar to those on a VCR or DVD player.
TIP: If you accidentally make any of these items disappear, place your cursor on the
Window menu item at the top of the screen, press and hold down the mouse button,
then drag downward and release it over the Window you want to see.

                                                
4 In this guide, Macintosh computers and operating systems are called “Mac” and Windows systems “Win”.
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2. THE STAGE
Here, you view the dancer from various angles, as if you are walking around the
stage.

                       
 2.1 To activate the STAGE window, position the cursor on its title bar and click the

mouse button once (the title bar becomes vivid).
 2.2 Imagine that the dancer and stage are fixed but that you are moving around her.

Initially – by default – you watch the dancer as if you are seated in the audience of a
raked theatre. To look at the dancer from various vantage points, position the cursor
over the View menu item (all menu names are visible at the very top of the screen).
Press and hold the mouse button down to see the list of menu choices. To select a
different view, position the cursor over the View menu item, press and hold down the
mouse button, then drag downward and release it over the View you want (notice that
a check mark (√) precedes your choice). To watch the dancer from straight on, select
View menu > Front. To view her from the raked audience again, select View menu >
Default (Mac) or top right scroll bar  (Win) as explained below. You can move
around the stage to see the dancer from Stage Right, Back, Top, etc.

 2.3 To see different areas of the stage from different angles, use the scroll bars
along the right side and bottom of the window. The controls at the bottom allow you
to circle around the dancer through 360° clockwise  or counterclockwise .
(When you go clockwise, the dancer appears to move counterclockwise and vice
versa.) The control at the top right side  allows you to rise above the stage to look
down at an angle on the dancer. The Zoom Bar just below moves you quickly closer



PART A: Exercise 1 5

or farther away. To move more slowly towards or away from the dancer, press the
“Z” key or the “X” key. If your dancer appears to have wandered off, press the “A”
key to get her attention. She will reappear, centered in the window.

 2.4 In the STAGE window, you will be able to change the dancer’s stage location.
In Front view, position the cursor on her body, then press and hold the mouse button
down as you move her stage left or right. To move her upstage or downstage, change
the view to Right. As you move the dancer, notice that the numbers change in the
boxes on the left of the window. These boxes contain the numbers that represent the
dancer’s position, the angle she faces, etc.

 2.5 Click anywhere in the STAGE window near the dancer to deselect her (her
colour becomes less pronounced). Then click on the dancer (her colour becomes more
vivid) and you will see that several things appear near the top left of the STAGE
window (see    icons on previous illustration). The box to the right of the
facing icon ( ) shows you the direction the dancer is facing (0.00 means she is
facing front). The box to the right of the altitude icon ( ) shows you how high the
dancer is off the stage (0.00 means she is standing on the stage). The box to the right
of the location icon ( ) shows you the dancer’s position in relation to stage left or
stage right, and the box just below that shows you her position upstage or downstage
(0.00, 0.00 means centre stage).
Below the last box is the Figure Status grid:  . More on this later.

3. THE STUDIO
Here, you can view the dancer’s body from various angles, as if she is working in the
studio and you are walking around her.
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 3.1 Click on the title bar of the STUDIO window to activate it (the title bar
becomes vivid). Then click once on any of the small dancers at the right of the
window to swap that view with the main view (try all three).

 3.2 Use the scroll bars along the right side and bottom of the STUDIO window to
change your vantage point. Explore these as you did in the STAGE window to change
your view of the dancer.
TIP: If you lose the dancer again, you can find her by pressing the “A” key.

 3.3 Double click on the dancer to select her. She becomes highlighted (more vivid).
Click anywhere near the dancer to deselect her (her colours become less bright). Then
click once on her Head. Notice that it becomes highlighted and that several controls
become active along the left side of the STUDIO window. These control the
orientation of the highlighted part. Place your cursor on the Head, press and hold the
mouse button down, and move the Head to one side then the other. As the head tilts,
notice how the values on the left side of the window change. More about these later.
TIP: To get the Head straight again, make sure that part is highlighted, then select
Edit menu > Reset to Default Shape.

4. THE SCORE
Here you see a series of keyshapes that make up a DanceForms dance phrase.

 4.1 At the left side of each dancer’s SCORE is an identifier. This dancer is named
“Rose”. Each dancer will have his or her own line in the SCORE.

 4.2 Just below the Title Bar (“Exercise1.lfa:Score”) is the Time Bar, a row of frame
numbers (1, 2, 3, etc.). The row below shows time markers, M:S:Frame, i.e., minutes:
seconds: frame. Frame 1, for example, is 0:00.0. Since dancers usually count in
musical bars and phrases, DanceForms will rarely refer to these clock time markers.
For now, we can think of one frame as one count (the start frame is “0”).

 4.3 At the left side of the SCORE window, just below M:S:Frame is the dancer’s
name or role identification. Below that is information about Location ( ): where she
is on stage; Altitude ( ): how high she is off the stage; Facing ( ): where she is
facing on the stage; and Snap (more later). The lowest row is for typed notes (  ).5

                                                
5 If Notes are not visible below Facing, enlarge the Score window by dragging at its bottom right.



PART A: Exercise 1 7

A keyframe is a frame in the SCORE that contains one or more basic elements:
Keyshape, Location, Altitude, Facing, Snap, Notes. The combination shown above
consists of five keyframes followed by several empty frames.

 4.4 Position the cursor on the M:S:Frame Time Bar of Frame 1 (the cursor shape is
an arrow) and click once. Frame 1 is active (the frame number and time marker are
red, and a red vertical line extends through the centre of the frame as shown below).
A coloured vertical line and shorter vertical rectangle appear to the left of the frame:
this marks the insertion point, the place where a new frame or series of frames can
be added (more on this later).

 4.5 To select Frame 1 (as you would select a word in a text editor), place your
cursor near the top left of Frame 1 just below the M:S:Frame Time Bar (the cursor
shape is a cross), press and hold the mouse button down, then drag across the frame
from one side to the other. A coloured rectangular box surrounds Frame 1 to show
that it is selected.
TIP: It is important to take note of the difference in marking an insertion point (a
long vertical line with a shorter vertical rectangle appears when you click once
between frames, as when you insert a letter or word in a text editor) versus selecting a
frame (a rectangular coloured box appears when you drag across a frame, as when
you select a word/words in a text editor). More on these later.

Selecting an insertion point:  Selecting a frame: 

5. ARRANGING THE WINDOWS
You can rearrange these four windows in various places on the screen.

 5.1 To move a window, position the cursor on the title bar, press and hold the
mouse button down, drag the window to where you want it, then release the mouse
button.

 5.2 To resize a window, use the Drag Box at the bottom right of the window. To
expand a window to fill the screen, click on the Zoom Box at the upper right corner:
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 (Mac)  (Win). To display only the title bar, click on the Collapse Box 
(Mac)  (Win). To close a window click on the Close Box  (Mac)  (Win).

 5.3 To make the STAGE, STUDIO and SCORE windows tidy and visible, choose
Window menu > Arrange or type “ +D” (Mac) “Ctrl+D” (Win).

6. THE PANEL: WATCHING A DANCEFORMS DANCE PHRASE
The PANEL works like VCR controls.

Mac  Win 

 6.1 To watch the DanceForms combination from the beginning, click once on
Frame 1 in the SCORE (the vertical red line appears through Frame 1), then click

once on the green Play button  on the PANEL window. Notice that the program
generates the movements between keyframes smoothly and continuously. To stop,
click on the red Stop button. Notice also that the horizontal scroll bar and number
show the frame that is currently selected or playing.

 6.2 To speed up the tempo, drag the triangle pointer toward the hare icon. To slow
it down, drag the pointer toward the tortoise icon. Click on Play again.

 6.3 To watch the combination one time, click on the icon at the bottom right of the
PANEL. When it is grey  (Mac) or white  (Win) the sequence plays once.
When it is coloured  (Mac) or inverted  (Win) the sequence repeats until you
click on the Stop button.

 6.4 To step through the combination one position at a time, click once or repeatedly

on the single frame forward/backward buttons:  or  (Mac)  or  (Win).
 6.5 Now you can explore viewing the combination from different angles using the

techniques introduced in this exercise.
IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Change your perspective to watch the dancer from different angles in the STAGE, the

STUDIO and the SCORE windows.
2. Move the windows around so you can see a DanceForms dance phrase clearly.
3. Use the PANEL to play the dance phrase.
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Exercise 2. Creating a Port de Bras: Exploring Sequence and Timing

As described in Exercise 1, a DanceForms dance phrase consists of two or more body
positions, as for example a ballet port de bras. In the Royal Academy of Dance, a “basic
port de bras” links three arm positions: arms start bras bas, move through 1st to 2nd, and
end bras bas.

                      
In Exercise 2 we explore how to sequence these set positions in the STUDIO by using a
palette of custom-made arm positions. We then learn how to make each position a
keyshape in the proper sequence in the SCORE and how to watch the port de bras on the
STAGE.

Ports de bras are normally done to a slow tempo such as Adagio. In DanceForms we can
watch the dance phrase at a range of tempi by moving the sliding triangle on the PANEL,
like slow motion or scan or your VCR.

Finally we learn how to phrase the sequence. The simplest phrasing would take one bar
of 3/4 music:

Starting Position: bras bas
Count 1: 1st

Count 2: 2nd
Count 3: bras bas

Another phrasing would be one bar of 4/4 music:
Starting Position: bras bas
Counts 1-2: open through 1st to 2nd

Counts 3-4: close bras bas

In DanceForms we change the time signature by adding or deleting empty frames in the
SCORE, so that a transition between any two keyshapes takes more or less time.
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1. Open “Exercise2.lfa” (File menu > Open…“Exercise2.lfa”. Be sure to select
). SHORTCUT: If you see the menu icon  (Mac) or the

Animations menu (Win) at the top of the screen, you can open an animation directly
from it: place your cursor over the item, press and hold down the mouse button, then
drag downward and release it over “Exercise2.lfa”. If this item is not visible along the
top of your screen, select File menu > Open… DanceForms menu.
 In this Exercise we get Rose to do a port de bras by using palettes that contain
custom-made dance positions we call keyshapes. Using palettes can simplify your
work. Ballet Moves and Modern Dance Moves offer hundreds of these pre-defined
positions. You can also refine all DanceForms palettes as you like, or define your
own set of palettes from scratch (see Part B Exercise 10 and Part C Exercise 11).

1.1 Open the palette titled “Exercise2.lfp” (File menu > Open… “Exercise2.lfp”
Be sure to ).
SHORTCUT: If you see the Palette icon  (Mac) or the Palettes menu (Win), at the
top of the screen, you can open the palette from it: press and hold down the mouse
button, then drag downward and release it over “Exercise2.lfp”. If this item is not
visible at the top of your screen, select File menu > Open… DanceForms Palettes.

When you open the “Exercise2.lfp” palette, it appears on the left of the screen. If the
palette hides the SCORE window, resize and reposition the window until it is visible.
SHORTCUT: To Arrange all windows, press +D (Mac) Ctrl+D (Win).

2. To create the Port de Bras combination, we use positions #2.1 - #2.3 from the palette.
 2.1 In the SCORE window, drag across Frame 1 to select it (it is surrounded by a

rectangular box). You will see the dancer waiting to get started.
 2.2 Click in the STUDIO window to activate it. The window displays the dancer in a

waiting position, Front view. If needed, press the “A” key to centre the dancer in the window,
then double click on the dancer to Select All body parts (the colours become more vivid).

 2.3 Move the cursor to the palette over the position #2.1 and click on it. (TIP: Click with a
quick, light action. If you hold the button down and a menu appears, select Assume.) The
STUDIO, STAGE and SCORE will now show the dancer starting in 1st position bras bas.
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 2.4 Now we are ready to show the first movement of the port de bras. Advance to Frame 2,
by moving the cursor to the PANEL.

Mac  Win 

Then click once on the forward step button  (Mac)  (Win).
Note that a red vertical line appears through Frame 2 in the SCORE.

 2.5 Repeat step 2.3, moving the cursor to the palette over position #2.2 and clicking on it.
The dancer will Assume 1st position arms 1st in Frame 2.

 2.6 Advance to frame 3 (  or  ), then repeat step 2.5, this time choosing palette
position #2.3. The dancer will Assume 1st position arms 2nd in Frame 3.

 2.7 Advance to frame 4, this time clicking on position #2.1. The dancer will Assume 1st

position bras bas in Frame 4.
 2.8 The port de bras now consists of a starting position and a three-count phrase which you

could count as one bar of 3/4 music. To clarify the timing you can add count numbers below
each frame. Click in the bottom area of Frame 1, to the right of the notes icon (  ). In Mac
systems, you will see a blinking vertical line (a text insertion point). In Win, you will see an
Edit Note Here window. Type “Starting Position”. In Win systems you will need to close the
Note. Next, click at the bottom of Frame 2 and type “Count 1”, etc.

The SCORE looks like this:   

3. WATCHING A DANCEFORMS COMBINATION

 3.1 In the PANEL, click on  (Mac) or  (Win) to return to the beginning

(Frame 1), then click on the green Play button .
 3.2 To play the exercise at a slower speed, drag the triangle at the bottom of the

PANEL toward the tortoise icon on the left, and repeat step 3.1. If you want the
exercise to keep repeating, click on  to turn on looping: the button colour changes
to  (Mac) or inverts  (Win). To stop the exercise, click on . Note that, in this
combination, one frame represents one count of music.
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4. CHANGING THE TIMING
To change the timing of the combination from one bar of 3/4 music (3 counts) to 4
bars of 3/4 music (12 counts), you need to add several frames.

 4.1 For example, to show that the arms take 3 counts (1 bar) to move to 1st position,
click between Frames 1 and 2 to get an insertion point (a vertical line with a shorter
vertical rectangle), then press the space bar twice. Type the new count numbers in the
Notes below Frames 2 to 4 (see below).

 4.2 Continue by adding new frames. Click between Frames 4 and 5 to get an
insertion point, then press the space bar twice. As shown below, add new frames and
Notes up to Frame 13 to complete bar 4 count 3. The SCORE looks like this:

     
 4.3 Watch your combination. Think of the Starting Position as the dancer’s

preparatory count “and” – signalling you to begin. Click on the green Play  button
and start counting: “1, 2, 3; 2, 2, 3; 3, 2, 3; 4, 2, 3” (each boldface number shows count
1 of each bar). Notice that the program generates the movements between keyframes
smoothly and continuously.
[Note: This 4-bar combination uses 13 frames: a starting frame + 3 frames per bar.]

5. Watch the combination at various speeds (see step 3).
6. You can also watch the combination frame by frame:  or  (Mac)  or  (Win).
7. View it from various vantage points by using the controls described in Exercise 1.
8. To save the file of your Port de Bras, select File menu > Save As…, then type your

name in the dialogue box that appears, e.g., 
Congratulations! You have successfully created your first DanceForms combination.
To see one set of examples, close your file (File menu > Close), then open
“Exercise2Examples.lfa” (select File > Open… Exercise2Examples.lfa).

IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Make the dancer assume a palette position in the STUDIO.
2. Sequence palette positions in the SCORE to create a dance phrase.
3. Change the timing of the dance phrase in the SCORE.
4. Watch the dance phrase on the STAGE.
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Exercise 3. Creating a Jump Combination: Exploring Altitude

1. Open “Exercise3.lfa” (File menu > Open). Meet Ben, one of our male dancers.
SHORTCUT: Place your cursor over the Animation menu icon  (Mac) or the
Animation menu (Win) at the top of the screen, click and hold down the mouse
button, then drag downward and release it over “Exercise3.lfa”.
In this Exercise we learn how to make Ben jump.

2. Open the “Exercise3.lfp” palette (from the File menu or Palette menu). To create the
Allegro sequence, we use positions #3.1 - #3.3 from the palette. In Exercise 2 we
learned how to make the dancer in the STUDIO assume palette positions. As we
changed each position in the STUDIO, DanceForms added it to the SCORE. In this
Exercise we learn how to put palette positions directly into the SCORE.

 2.1 Click in the SCORE between Frames 1 and 2 to get an insertion point (a long
vertical line and shorter vertical rectangle appears to the left of Frame 2). The
STAGE and STUDIO windows echo this frame, displaying the dancer in a waiting
position.

 2.2 Move the cursor to the palette over the position #3.1 and click on it. (TIP: Click
with a quick, light action. If you hold the button down and a menu appears, select
Assume). The STUDIO, STAGE and SCORE now show the dancer in 1st position
bras bas, the starting position for the jump.

 2.3 The insertion point is now to the left of Frame 3. Move the cursor over the
palette and click in sequence on the following palette positions: #3.2, #3.3, #3.2, #3.1.
The SCORE looks like this:

 2.4 To watch this combination, click on the frame number above the starting
position (Frame 2), then click on  in the PANEL. Move the triangle  to change
the speed. To watch directly from front, click in the STAGE window, then select
View menu > Front. Press the “A” key to centre Ben in the window, and watch again.
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 2.5 As you watch the movement, notice that the dancer’s feet appear to stay on the
stage floor. This is because DanceForms initially (by default) “pins” the lowest body
part at floor level (see Figure menu > √Pin to Floor). To make Ben jump, you will
need to show him rising into the air and returning to the ground. In DanceForms,
what goes up doesn’t automatically come down.

3. To make Ben jump, you will use the altitude controls.
 3.1 In the SCORE, click above the position with legs fully stretched (Frame 4).
 3.2 In the STAGE window, click on the dancer to activate his controls. If the palette

covers these, rearrange the windows by selecting Window menu > Arrange.
SHORTCUT: +D (Mac) Ctrl+D (Win).
Note that the frame number “4” appears in the bottom left corner of the STAGE
window and that two sets of arrow controls and several boxes appear at the top left.

                           The top arrows are the altitude controls: 
There are several ways to set the altitude.

 3.3 First, place your cursor on the top arrow, then press and hold the mouse button
down. Notice that the number in the altitude box increases as the dancer in the
STAGE window rises. (You may need to click on the altitude box to see the new number.)

 3.4 You can also type a number directly into the altitude box: position the cursor in
the box, double click to highlight the number (it becomes coloured), then type “0.20”,

i.e.,  .
When you set the altitude for a dancer in a frame, the altitude icon  appears in the
STAGE window Figure Status grid, beside the dancer identification (  for Ben).
The altitude “0.20” also appears in the SCORE below the body keyshape in Frame 4.

 3.5 Click above Frame 2 in the SCORE and watch the combination again. Now Ben
appears to rise gradually until Frame 4 and stay at that height until the end. To keep
him on the ground until the pushoff and return him to the ground on the landing, you
need to explicitly set the altitude to “0.00” on the two pliés (Frames 3 and 5).

 3.6 To keep Ben on the floor until the push-off, click above Frame 3 in the SCORE,
click in the STAGE Window, place your cursor on the bottom arrow in the altitude
controls, then press and hold the mouse button down on the bottom arrow. Notice that
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the numbers in the altitude box decrease as the dancer in the STAGE window gets

lower, until he is on the stage floor (i.e., his altitude is “0”  ).
 3.7 To make Ben land, advance to Frame 5 (click twice on the forward step button

 or  in the PANEL), and repeat step 3.6.

In Frame 5, the dancer has now landed (i.e., his altitude is “0”  ).
 3.8 To watch the combination, click above the starting frame (Frame 2), then  .

Congratulations! Your dancer has now mastered the basic technique for jumping.

4. The rest of this Exercise explains how to make the jump look better, and how to build
different sequences and use different leg and arm positions. First let’s experiment
with ways to show that the legs stretch sooner and stay stretched longer.

 4.1 In the SCORE, get an insertion point after the jump by clicking once above
Frame 8 (a vertical line with a shorter vertical rectangle appears left of Frame 8).

 4.2 Move the cursor over the palette and click in sequence on the following palette
positions: #3.1, #3.2, #3.3. Then press the space bar once to add a new frame. Now
click in sequence on palette positions #3.3, #3.2, #3.1.

 4.3 In the STAGE, set Ben’s altitudes to “0” in the frames showing the plié
preparation and landing. Next, set his altitude to “0.20” in the empty frame (the frame
with no body keyshape showing).
The SCORE looks like this:

 4.4 Watch Ben’s new combination, and notice how his feet and legs stretch.

5. To create continuous jumps, experiment by copying and pasting a series of frames (as
you would Select, Copy and Paste a sentence in a text editor):

 5.1 In the SCORE, hold down the mouse button and drag from the Frame 10 take-
off to the Frame 13 landing (a rectangular box surrounds Frames 10 to 13 to show
that they are selected), then select Edit menu > Copy.
SHORTCUT: +C (Mac) Ctrl+C (Win).
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 5.2 In the SCORE, click above Frame 14 to get an insertion point after the landing
position, then select Edit menu > Paste.6

SHORTCUT: +V (Mac) Ctrl+V (Win). The SCORE looks like this:

 5.3 Watch Ben’s two-jump combination.
6. To create other jumps, use different positions from the palette.

 6.1 In the SCORE, click to get an insertion point a few frames to the right of the
last jump, then add positions by clicking on them in the palette.
For example, to create an échappé sauté sequence, follow the steps below:

 6.2 Click in sequence on #3.1, #3.2, #3.4, press the space bar, #3.5, #3.6, #3.5,
press the space bar, #3.7, #3.2, #3.1.

 6.3 Specify “0” altitude for the three frames showing the plié landing/push-off.
SHORTCUT: You have already learned how to change altitude with controls in the
STAGE window. You can also set it in the SCORE by changing an implicit altitude
(the last altitude set) into an explicit keyframe. For example, drag across the plié, then
select Edit menu > Key Frame > Altitude. Now “0.00” appears below the keyshape.

 6.4 Specify “0.20” altitude for the empty frames to show how high Ben rises.

 6.5 Watch Ben’s longer jump combination.
7. To make Ben land “through his feet” we add a keyframe just before each landing.

 7.1 Click above the landing in 2nd position in the SCORE to get an insertion point to
the left of that frame, then click on #3.8 in the palette (see first arrow below).

 7.2 For the new landing position, set the altitude to “0” in the STAGE.
 7.3 Click above the landing in 1st position in the SCORE to get an insertion point to

the left of that frame, then click on #3.9 in the palette (see second arrow below).
 7.4 For this new landing position, set the altitude to “0” in the STAGE.

                                                
6 Before you Paste, it is good practice to check Paste Defaults. For now, select Edit menu > Paste Defaults
> √Absolute Location √Absolute Facing. Deselect Comment Pastes if you do not want to show where the
frames originated. Otherwise, text may appear in the Notes area to show the originating file name.
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8. Now let’s add a metronome beat to help Ben learn to land on the musical count.
 8.1 Select Sound menu > Sound File… > Choose > 2bps120bpm.aif. Click Convert

then OK (Mac). In Windows you must select Files of type: All Files before choosing a
file name.7 (More on adding Sound files and changing rhythm in PART C Exercise 16.)

 8.2 Select Control menu > Frame Rate… >, enter “4” in the box to the right of Frames
per second, then click OK.

 8.3 In the PANEL, move the triangle to the centre and watch the jump combination
again. The Allegro metronome sounds at a rate of 120 beats per minute (2 beats per
second) and the animation plays at a rate of 4 frames per second.
Notice when the landings do not correspond to the metronome beats.

 8.4 Change the timing by adding new frames to the SCORE: click above the frame
showing the start of a jump combination to get an insertion point, then press the
spacebar once to add a new frame. Repeat as needed to move each frame showing a
landing position to Frame “0” (the numeral to the right of the decimal point) in the
M:S:Frame Time Bar, wherever possible.                                 

TIP: Here the timing is just off, since the frame rate is 4 fps and the jump takes 5 frames.
9. To save the file of your Allegro combination, select File menu > Save As…, then type

your name in the dialogue box that appears, e.g., .
If you want to see examples, close your file (File menu > Close), then open
“Exercise3Example1.lfa” or “Exercise3Example2.lfa” (select File > Open…).

IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Put palette positions directly into the SCORE.
2. Create a jump by setting the dancer’s altitude on the STAGE at the push-off, in the air,

and on the landing.
3. Make the jump look better by stretching the legs quickly on the push-off, sustaining

the stretch in the air, and landing through the feet.
4. Add a metronome beat and change the timing to show landing “on the beat”.
                                                
7 In Windows, be sure that the sound file name has a .aif extension. If the extension is missing, you need to
rename the file adding the .aif extension before you choose it in the Sound menu.
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Exercise 4. Creating a Turn: Exploring Facing and PERFORMANCE

1. Open “Exercise4.lfa”. In this Exercise we learn how to change the facing of the
dancer to create turning movements like pirouettes or spiral turns.

2. To add body keyshapes for a pirouette, open the “Exercise4.lfp” palette.
 2.1 In the SCORE, click above Frame 1 to get an insertion point to the left of Frame

1, then click on palette positions in the following order: #4.1, #4.2, #4.2, #4.1.

The SCORE looks like this:     
 2.2 Watch your combination and note that Rose appears to hold the pirouette

position. This is because the same position is specified in Frames 2 and 3. Notice also
that this combination (a preparation for a pirouette) is done all facing front. Initially
(by default) DanceForms sets the dancer at a rotation of 0° (facing front).

3. To create a turn, you need to rotate the dancer through 360°. You do this in the
STAGE window. First, Copy the 4-frame combination and Paste it to the right:

 3.1 In the SCORE, to select the 4-frame combination, place your cursor to the left
of Frame 1, press and hold the mouse button down as you move the cursor to the right
of Frame 4, then release the mouse button (Frames 1 to 4 are surrounded by a
coloured rectangle).

 3.2 Select Edit menu > Copy.8 SHORTCUT: +C (Mac) Ctrl+C (Win).
 3.3 Click above Frame 5 to get an insertion point to the left of Frame 5, then select

Edit menu > Paste. SHORTCUT: +V (Mac) Ctrl+V (Win).
 3.4 Watch the 8-frame combination:

Now we need to add a 360° rotation from Frames 5 through 8.
 3.5 In the SCORE, click above Frame 5 to make it active (see a red vertical line).

                                                
8 Before you Paste, it is good practice to check that Paste Defaults are set correctly. Select Edit menu >
Paste Defaults > √Absolute Location √Absolute Facing. Deselect Comment Pastes if you do not want text
to be pasted. For now, leave all other options as set.



PART A: Exercise 4 19

 3.6 In the STAGE window, click on Rose to activate her controls. If the palette
covers these, rearrange the windows by selecting Window menu > Arrange.
SHORTCUT: +D (Mac) Ctrl+D (Win). We want Rose to do one preparation facing
front, so we need to explicitly set her facing control at “0” in Frame 5. To do this,
select Edit menu > Key Frame > Facing. Notice that the facing icon  now appears
in the STAGE window beside Rose’s Figure Status grid . The SCORE
now displays a facing of “0” below the body keyshape in Frame 5.

 3.7 In the SCORE, click above Frame 7 to get an insertion point to the left of that
frame, then press the spacebar once to add a new frame. You now have a 9-frame
combination (see below). Click above Frame 6 to make it active.

 3.8 To understand how the dancer turns, think of taking a bird’s eye view. In the
STAGE window, select View menu > Top. Type “A” to centre the dancer. To change
the facing angle in Frame 6 (the pirouette position), you will use the horizontal
arrows  at the top left of the STAGE window. To turn the dancer
clockwise, place the cursor on the left arrow , then press and hold the mouse
button down. Watch Rose turn clockwise as the number in the rotation box increases.
(You may need to click on the rotation box to see the new number.) When the number
is about “90.00” and the dancer faces Stage Right, release the mouse button and she
will stop turning. If you pass “90.00” use the  arrow to bring Rose back.

 3.9 Use the PANEL  (Mac) or  (Win) to advance to Frame 7, and notice that
Rose’s facing angle is still about “90.00”. To continue the turn, double click on the
number “90.00” in the STAGE window and type “180.00”. Rose faces Upstage.

 3.10 Advance to Frame 8, double click on the number “180.00” and type “270.00”.
Rose faces Stage Left.

 3.11 Advance to Frame 9, double click on the number “270.00” and type “360.00”
or “0.00”. She now faces Downstage (front). The SCORE looks like this:

Notice the facing angles under Frames 5 to 9. If you entered whole numbers, Dance
Forms may change them to decimal numbers (more on this soon).
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4.  4.1 Watch the turn combination from the beginning in the Top view.
 4.2 Now watch it again from the Front (View menu > Front).
 4.3 Next we put Rose’s practice clothes on. Select Window menu >

PERFORMANCE. SHORTCUT: +R (Mac) Ctrl+R (Win).
Now watch the combination again and notice that the turn is even.

5. There are several methods to improve the look and quality of the pirouette, such as
altering the rate of turn or adding spotting.
Let’s create a sharp turn with spotting, in the fewest number of keyframes:

 5.1 Click in the SCORE to get an insertion point to the left of Frame 12. Then click
on palette positions in the following order: #4.1, #4.3, #4.4, #4.1. Watch the
combination without a turn, and notice the head positions. Now we’ll make Rose turn.

 5.2 In the SCORE, click above the start of this sequence (Frame 12). Then in the
STAGE window click on Rose to activate her controls. Set the rotation number to

“0.00”. Click on  or  to advance to the next frame. Set the rotation number to
“91.00”. Rose turns to face Stage Right but her head “spots” to the front. Advance to
the next frame and set the rotation number to “269.00”. Rose turns to face Stage Left
and her head again “spots” to the front. To end the turn facing front, advance to the
next frame and set the rotation number to “360.00” (or “0.00”).

Notice that the facing angle appears below the corresponding frame in the SCORE.
As the SCORE window gets smaller the number may change to the facing icon .
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The SCORE now looks like this:   
 5.3 Watch your combination in the STAGE window. SHORTCUT: +L, +P

(Mac) Ctrl+L, F8 key (Win). Watch again in the PERFORMANCE window.
SHORTCUT: +R, “ ` ” key (Mac) Ctrl+R, F8 key (Win).

TIP ON DEFINING TURNS: DanceForms automatically calculates the shortest distance
between angles of rotation. For a turn of exactly 180°, DanceForms does not know
whether to turn the dancer left or right. All turns must therefore be less than 180° (if
you type 180, DanceForms will change the number to 179.99). To show a full
revolution of 360° starting facing front, you need to specify a starting position (0°)
plus at least three keyframes, e.g., 120°, 240°, 360° for a smooth turn, or 91°, 269°,
360° for a sharp spin.

6. So far Rose has turned only clockwise. To turn her counter-clockwise, you need to
reverse the sequence of facing angles, e.g., 0°, 270°, 180°, 90°, 0° or 360°. Or you can
select the entire turn in the SCORE, then select Edit menu > Mirror > (click in the
boxes to add check marks before √ Right Left (x), √ Facing, and √ Shapes; leave the
Snap defaults for now). Then click “Mirror”. SHORTCUT: +M (Mac) Ctrl+M (Win).

7. Save the file of your Pirouette combination (File menu > Save As…).
If you want to see examples of turning movements, close your file (File menu >
Close), then open “Exercise4PirouetteExample.lfa” or “Exercise4SpiralExample.lfa”.

IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Create turning movements by setting the dancer’s facing at the start and end of each

turn, ALWAYS specifying increments of less than 180°.
2. Create smooth turning movements by changing facings in even increments, e.g.,

clockwise 90° + 90° + 90° + 90° (facing 0°, 90°, 180°, 270°, 360° or 0°) or
120° + 120° + 120° (facing 0°, 120°, 240°, 360° or 0°).

3. Create sharply turning movements by showing “spotting” and changing facings in
uneven increments, e.g., 91° + 179° + 90° (facing 0°, 91°, 270°, 360° or 0°).

4. Create counter-clockwise turns by reversing the sequence of facings, e.g., facing 0°,
269°, 90°, 0°; or by using the Mirror command.

5. Watch the combination in the PERFORMANCE window.
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Exercise 5. Creating a Battement Brush:
Exploring “Tweening” and Refining Body Positions

1. Open “Exercise5.lfa”. Meet Resa. In this Exercise we learn how to change the
dancer’s body position to create new keyshapes. We’ll learn how to refine Resa’s
movements to make her do a side brush. We’ll see what decisions DanceForms makes
automatically and learn what decisions you need to make explicitly.

2. To add body keyshapes for the brush, open the “Exercise5.lfp” palette.
 2.1 In the SCORE, click above Frame 1 to get an insertion point to the left of Frame

1, then click on palette positions in the following order: #5.1, #5.2, #5.2, #5.1.

The SCORE looks like this:    
 2.2 Click above Frame 1 in the SCORE and watch the combination in the

PERFORMANCE window. SHORTCUT: +R, +P (Mac) Ctrl+R, F8 (Win).
To see the floor more clearly, watch in the STAGE window from straight on.
SHORTCUT: +L, +1, “ ` ” key (Mac) Ctrl+L, Ctrl+1, F8 key (Win).
Note that the supporting foot appears to move inward, centred under the hips for
balance. Look at Frame 1 in the STUDIO to see the weight centred over both feet.
Use the PANEL  or  to advance to Frame 2. Note that the supporting leg
position has changed to centre the body weight over the left foot. We see this as a
shift of the pelvis but anatomically it is a change at the supporting hip joint and ankle
joint.

 2.3 Watch the combination again. Note that Resa appears to “pop up” as the leg
brushes from 1st position to side and again as it returns to 1st position.

3. Watch the brush more slowly:
 3.1 In the PANEL, move the triangle  toward the Tortoise icon on the left.
 3.2 In the SCORE, click above Frame 1 and watch the combination again.

4. To see what causes this unexpected “pop up”, click between Frames 1 and 2 to get an
insertion point in the SCORE, then press the space bar once to add a new frame. Do
the same before the final frame.

The SCORE looks like this:     
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  4.1 Notice that DanceForms generates smooth, continuous movement between
keyframes. This is called “in-betweening” or “tweening”. Click above Frame 2 in the
SCORE to select it, then click on the STUDIO window to activate it. Press the “A”
key to centre Resa in the STUDIO window, and look at her position from Front view.

 
 4.2 Notice that the ankle of the extended leg is halfway between its standing

position and its stretched position, and that its toes are lower than the sole of the
supporting foot. DanceForms is preset to “pin” the lowest point of the dancer’s body
to the floor, so in this frame the supporting foot appears to be off the floor (see Figure
menu > √Pin to Floor).

5. Before we experiment by changing the position of the right foot, read on.
TIP: In Front view Resa is facing you, so her right foot is on the left side.

 5.1 In the STUDIO window (Frame 2), click on the right heel to activate the body
part called RFoot. That body part is now highlighted, its name appears near the
bottom right of the STUDIO window, and its controls become visible along the left
side of the window. Two globes appear, with a coloured line in the Near globe
showing the orientation of the RFoot segment from the selected view (Front view).
Look at the X-box and note that DanceForms automatically “tweens” the values of
Frame 1 (X = 0) and Frame 3 (X = -60), i.e., about -30:
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THE FOLLOWING EXERCISE IS A BRIEF INTRODUCTION TO THE
DANCEFORMS STUDIO. FOR MORE INFORMATION SEE PART B.

 5.2 There are many ways to change the position of a body part. Try these:
a) Drag the coloured line on the globe to change the ankle position. Think of these
controls as showing latitude and longitude markings on a globe.
b) Drag the red line above the X-value box to change only the flexion-extension of
the toe segment (watch the numbers change in the X-box only).
c) Drag the green line above the Y-value box to change only the adduction/abduction.
d) Drag the blue line above the Z-value to change only the inversion/eversion.9

 5.3 To erase a body keyshape you do not like, you can Clear the frame: drag across
Frame 2 in the SCORE to select it, then select Edit menu > Clear >  Shape or press
Ctrl+S (Mac).

 5.4 To reposition the foot so that the sole is flat, place your pointer on the up arrow
beside the X-box value, then press and hold down the mouse button. Watch the
numbers in the box change until the RFoot looks parallel to the floor.

 5.5 Watch the combination again. Continue to change the RFoot position until she
remains on the floor throughout her brush. If you are having trouble, drag across
Frame 2 in the SCORE then Clear the body keyshape (Edit menu > Clear > Shape).
Select Resa’s RFoot in the STUDIO window and type “-10.00” in the X-value box.10

Make the same RFoot adjustment in Frame 5, the transition to close 1st position.
 5.6 Watch the brush combination again. Now Resa stays on the floor, but her

supporting foot still moves inward.

6. To keep Resa’s supporting foot in place in the STAGE or PERFORMANCE window
so that her hips shift over her foot (rather than her foot moving below her hips), we
will use the Auto Snap command.

 6.1 Drag across Frames 1 to 6 to select the brush (a coloured rectangle surrounds
the 6-frame combination), then select Snap menu > Auto Snap. Make sure that a
check mark (√) precedes only Snap Location in the Snap menu.

 6.2 Click above Frame 1 in the SCORE, then watch the combination. Notice that
the supporting foot now stays in place. Notice also that a black mark appears in the
SCORE to illustrate that the LToes are Snapped.

                                                
9 This action is not possible for each toe (See Appendix A), but a DanceForms figure can move any way.
10 You may notice that DanceForms changes the values you specify in these boxes, adjusting them
according to its coordinate system.
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7. At least two transitional frames are needed to show a technically correct battement
brush, articulating through the Foot, Arch and Toes.11 These are shown in the palette:

 7.1 To make a new brush combination, click in the SCORE above Frame 10 to get
an insertion point after your brush combination.

 7.2 To create the opening of the technically good battement brush, click in
sequence on the following positions in the palette: #5.1, #5.3, #5.4, #5.2.

 7.3 To create the closing of the brush, click in reverse order: #5.2, #5.4, #5.3, #5.1.
 7.4 To keep Resa’s supporting foot in place, use the Auto Snap command: drag

across the 8-frame combination in the SCORE, then select Snap menu > Auto Snap.
(More on the Snap feature later.)

 7.5 Watch the combination in the STAGE window: +L, +P (Mac) Ctrl+L, F8
(Win). Watch it again in the PERFORMANCE window: +R, +P (Mac) Ctrl+R,
F8 (Win). View it from various angles and at different speeds.

8. Save your brush combination (File menu > Save As…).
If you want to see one set of examples, close your file (File menu > Close), then open
“Exercise5Example.lfa” (select File > Open… Exercise5Example.lfa).

IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Add new frames in the SCORE between body keyshape frames to explore how

DanceForms automatically “tweens” by showing transitions between positions.
2. Modify tweened positions in the STUDIO to add new body keyshapes to the SCORE,

creating detours for better transitions.
3. Use the Auto Snap command to snap the lowest body part to its previous location on

the floor, creating the illusion of a weight shift.

                                                
11 See Appendix C and D for lists of Ballet Moves and Modern Dance Moves brushes in all directions.
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Exercise 6. Creating a Walk: Exploring Location, Paths and Snap

1. Open “Exercise6.lfa”. Meet Jacques. In this Exercise we learn how to change the
dancer’s Location on the STAGE, to show standing up and walking.

2. To add body keyshapes for the combination, open the “Exercise6.lfp” palette.
 2.1 In the SCORE, click above Frame 1 to get an insertion point to the left of Frame

1, then click on palette positions in the following order: #6.1 - #6.17. Close the
palette. The SCORE now looks like this:

 2.2 Click on  or  to return to Frame 1, then watch the combination from the
Front view in the STAGE window. SHORTCUT: +L, +1, +P (Mac) Ctrl+L,
Ctrl+1, F8 (Win). Change to the PERFORMANCE window from Top view.
SHORTCUT: +R, +2 (Mac) Ctrl+R, Ctrl+2 (Win). You may need to drag the
stage or scroll to centre Jacques in the window. Now watch him stand up and walk in
place.

 2.3 To make Jacques stand up and walk forward, first change your View to Stage
Left in the SCORE (click on the title bar of the SCORE, then select View menu >
Stage Left). The SCORE now looks like this:

 2.4 Watch the combination again, this time from Side view in the STAGE.
SHORTCUT: +L, +3, +P (Mac) Ctrl+L, Ctrl+3, F8 (Win).
Now watch the combination from the Side view in the PERFORMANCE window.
SHORTCUT: +R, +3, +P (Mac) Ctrl+R, Ctrl+3, F8 (Win).

 2.5 It would be very tedious to manually move Jacques forward by changing his
Location in each frame. Fortunately, DanceForms can do this for us.

3. To make Jacques stand up on his left foot and take two steps that move him forward,
we’ll use the Auto Snap command. This feature “snaps” the lowest body part in the
selected keyframe or frames to its previous location on the floor.
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 3.1 First you need to set the starting position. In the SCORE, drag across Frame 1
then select Edit menu > Key Frame > All, or type +`(Mac). Notice that numbers
now appear for Jacques beside Location, Altitude and Facing in the SCORE. The
icons are also displayed in the STAGE window Figure Status grid.

SCORE:     STAGE:  Figure Status grid

 3.2 Now we will “snap” Jacques’s lowest body part in relation to the location of
this starting position. Drag across Frames 2 through 17 to select them (a coloured
rectangle surrounds them), then select Snap menu > Auto Snap. Make sure that a
check mark (√) precedes only Snap Location in the Snap menu. Notice that
DanceForms automatically sets new information and displays it in the SCORE below
each frame.

 3.3 Watch the combination again from the Side view in the STAGE window and in
the PERFORMANCE window. Jacques now stands up taking his weight onto his left
foot, then takes two steps forward.

 3.4 To see what DanceForms does, use the PANEL  or  to step through the
combination one frame at a time in the STAGE window, starting at Frame 1.
The Auto Snap command sets the lowest body part in a keyframe to its previous
location on the floor (√ Snap Location). Auto Snap works only if each keyshape is
correctly positioned. For example, the Pelvis is the lowest part in Frame 2 so it
“snaps” to the position set in Frame 1. The RToes segment is the lowest part in Frame
4 so it “snaps” to the position set in Frame 3, and so on.

4. Save your walk combination (File menu > Save As…).
If you want to see an example of this sequence, close your file (File menu > Close),
then open “Exercise6Example.lfa” (select File > Open… Exercise6Example.lfa).
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5. To understand what DanceForms automatically changes when you select Auto Snap,
look at “Exercise6Example.lfa” in the STAGE window +L (Mac) Ctrl+L (Win)
from the Top view +2 (Mac) Ctrl+2 (Win).

 5.1 Scroll in the STAGE window so you can see the downstage portion of the stage
as Jacques walks forward (drag upward anywhere on the stage, or use the scroll bar
along the right side of the window). To watch, press +P (Mac) F8 (Win).

 5.2 Click on  or  to return to Frame 1, click on Jacques to select him on the
STAGE, then look at the information that appears near the top left of the STAGE
window. Jacques starts centre stage: his Location is 0.00, 0.00.

 5.3 Use the PANEL  or  to step through the combination one frame at a time.
Note that the Location values change at Frame 4: Jacques has moved slightly to
toward Stage Right (-0.09) and Downstage (-0.18). By Frame 17 he is just right of
centre and further downstage (-0.22, -1.53).

 5.4 To see the line of travel, click on Jacques to select him on the STAGE, then
select View menu > Paths, or press +K (Mac) Ctrl+K (Win). Each new Location is
shown by a small rectangular node, all connected to show the Path.

The numbers specifying the width and depth of each new Location are also displayed
in the SCORE (shown as “ X ” when the SCORE is too small to show the numerals).
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6. OPTIONAL: You can manually move a dancer on the STAGE by dragging him to a
new location. Or you can type numeric values into the boxes to the right of the
Location icon ( ) above the Figure Status grid.

 6.1 To manually move a dancer forward, it is best to View him from Stage Left or
Right on the STAGE. SHORTCUT: +L, +3, +P (Mac) Ctrl+L, Ctrl+3, F8 (Win).

 6.2 Select View menu > √Previous Frame Ghost, then click on  or  to step
through the combination one frame at a time. A “ghost” appears as a frame of
reference to show how the dancer moves downstage in relation to each previous frame.
TIP: If you cannot see the ghost, change the STAGE colour (View menu > Stage >
Color…) or Background colour (View menu > Background > Color…) to make your
Figure contrast with the Background (try a light Figure against a dark Background).

 6.3 Drag across Frames 2 through 17 to select them, then select Edit menu > Clear
Location, and Edit Menu > Clear Snap. Watch the combination again, now done in
place.

 6.4 Starting at Frame 1 (location 0.0, 0.0), click on  or  to step through frame
by frame, and drag the dancer to a new location in relation to the supporting foot
shown by the Previous Frame Ghost. Note how the Location values change as you
drag the dancer.

 6.5 You can also move the dancer forward/backward on the STAGE by typing a
numeral into the Location boxes above the Figure Status Grid: the box to the right of
the Location icon ( ) controls the dancer’s location stage right/left; the bottom box
controls his location upstage/downstage.

As mentioned, this is a tedious way to move the dancer.
If you have positioned body keyshapes correctly, Auto Snap will do it all for you!

IN THIS EXERCISE YOU HAVE LEARNED TO…
1. Change the dancer’s Location on the STAGE by using the Auto Snap command.
2. Change the dancer’s Location on the STAGE by dragging him to a new Location with

the aid of Frame Ghosts.
3. Change the dancer’s Location on the STAGE by typing numerals in the Location

controls.
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PART B:
Working in the DanceForms STUDIO

These Exercises get you started creating your own body positions
and explain how to create your own palettes

or edit customized palettes, as on Ballet Moves and Modern Dance Moves

Exercise 7 Basic Terms of Reference
7.1 Anatomical Position
7.2 Anatomical Planes of Motion
7.3 Anatomical Terms

Exercise 8  Moving a Body Part
8.1 Rotating the Pelvis
8.2 Moving the Arms and Legs
8.3 Moving an Arm Outward
8.4 Moving a Leg Forward and Backward
8.5 Rotating the Legs
8.6 Bending the Knees and Elbows
8.7 Pointing and Flexing the Feet

Exercise 9 Moving Body Parts in Combination
9.1 Combining Upper and Lower Arms/Leg Actions
9.2 Creating Complex Arm and Leg Positions
9.3 More Limb Positions and Movements
9.4 Positioning the Pelvis First
9.5 “Tweening” Positions

Exercise 10 Using Palettes of Keyshapes
10.1 Using Customized Palettes of Dance Positions
10.2 Creating your own Palette of Dance Positions
10.3 Refining Palette Positions
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Exercise 7. Basic Terms of Reference

Launch DanceForms 1.0 and open a new animation (File menu > New
Animation). To add a dancer, select Figure menu > New Figure >
Female Modern (one of four DanceForms dancers).

The DanceForms dancers are idealized and “superhuman” – their body
parts can be moved into impossible positions and can even pass through
other parts. They can stay erect even when clearly out of balance. The
joints have no limits, gravity has no effect, and there is no friction on the
floor. To see examples, open “Exercise7TheStudio.lfa” and watch the
sequence.

This is how Resa, the Female Modern dancer, looks in the
PERFORMANCE window.

  
Each DanceForms dancer has 54 moveable body parts.

These are listed in the Body Parts menu, shown to the right for Mac
(slightly different for Win). To open the Body Parts Menu, click in the
STUDIO to activate the window, position your cursor just to the right of
the large figure, press and hold the mouse button down until the menu
appears, then drag to the left of the figure and release the button.

At the top of this menu are words that let you select groups of related
parts. Fingers, for example, are All Descendants of the Hand (more soon).

In the STUDIO, each body part pivots at the point where it joins the
adjacent part, its Parent. The one exception is the pelvis, which rotates
around its central point.
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7.1 ANATOMICAL POSITION

Below left is how anatomists look at the body in order to name basic joint actions.

Anatomical Position DanceForms Default (neutral)

In Anatomical Position, the body is erect. The arms hang so that the hands are below the
shoulders, palms facing forward. The feet are below the hips with knees facing forward.

The DanceForms Default (neutral) shown above right differs from the Anatomical Position
only in the positioning of the hands.

7.2 ANATOMICAL PLANES OF MOTION

                               
Sagittal Plane Horizontal Plane

 “WHEEL PLANE” (somersault) “TABLE PLANE” (pirouette)

                 
Lateral Plane

“DOOR PLANE” (cartwheel)
Open “Exercise7BasicMovements.lfa” and watch the sequence to see examples of
movement in each of these basic planes. Read the Notes at the start of each phrase, or listen
to Talking Notes narrate the action (Mac only).
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7.3 ANATOMICAL TERMS: BASIC TERMS FOR WHOLE LIMB ACTIONS

1. Flexion (or forward flexion) is movement of a whole arm or leg forward (in front of
the body). It occurs in the sagittal plane, and is shown by an increase in the X-box
value12 for an Upper Arm or Upper Leg.

2. Hyperextension (or backward flexion) is movement of a whole arm or leg
backward (behind the body). It occurs in the sagittal plane, and is shown by a
decrease in the X-box value for an Upper Arm or Upper Leg.

3. Extension is movement back to neutral in the sagittal plane.
4. Rotation is movement around the long axis of a whole arm or leg. It occurs in the

horizontal plane, and is shown by a change in the Y-box value for an Upper Arm or
Upper Leg. Clockwise rotation is an increase in Y-box value (i.e., positive) and
counter-clockwise rotation is a decrease in Y-box value (i.e., negative).

5. Lateral rotation is rotation of a whole arm or leg outward, away from the body
centre line. Standing with the feet parallel, the Upper Leg Y-box values are 0. As
the legs turn out, the RUpperLeg Y-box value increases and the LUpperLeg Y-box
value decreases.

6. Medial rotation is rotation inward, toward the body centre line. As the legs turn in,
the reverse occurs. The same for the Upper Arm rotation. For arm rotation,
additional twisting is possible below the elbows, whereas rotation is limited below
the knees.

7. Abduction (or sideways flexion) is outward movement of a whole arm or leg away
from the centre of the body in the lateral plane. It is shown by changes in the Z-box
value for an Upper Arm or Upper Leg.

8. Adduction is inward movement toward the centre of the body in the lateral plane. It
is shown by changes in the Z-box value for an Upper Arm or Upper Leg.

9. Circumduction is a composite action involving all the above movements to
produce circling of the limbs as, for example, in a big leg circle (a ballet grand rond
de jambe).

SUMMARY OF WHOLE ARM/LEG ACTIONS

Anatomical Term Plane of Motion Box Value

Flexion/Hyperextension Wheel X

Lateral/Medial Rotation Table Y

Abduction/Adduction Door Z

For a summary of anatomical joint ranges see Appendix A. To see an animation illustrating
these ranges, watch RangeofMotion.lfa and listen to the Talking Notes (Mac only).

                                                
12 NOTE: Box values can be either positive numbers (e.g., 27.43) or negative numbers (e.g., -27.43).
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Exercise 8. Moving a Body Part

8.1 ROTATING THE PELVIS

Open “Exercise8.lfa”. First we will rotate the pelvis sideways, as in a cartwheel.

Click on the title bar of the STUDIO to activate it. If needed, change your View to Front by
pressing the “F” key command. Click on the pelvis to select it (it becomes highlighted as
below left). Position the cursor near the top of the pelvis, hold the mouse button down, and
move the cursor horizontally left. TIP: If you hold the mouse button down too long before
you drag, a dialogue box appears to let you select from a short list of body parts.

The pelvis rotates, taking the torso and limbs along with it. Notice that the value in the Z-
box changes. You can specify the precise amount of rotation by clicking on the up and
down arrows to the right of the Z-box, or by double clicking in the box to select the value
and typing a numeral.

To make the pelvis horizontal, type “90” in the Z-box (see below right).
To return the pelvis to its starting position, make sure it is highlighted, then select Edit
menu > Reset to Default Shape. SHORTCUT: +/ (Mac) Alt+/ (Win).

Next we will rotate the pelvis forward/backward, as in a somersault.

Change your view to side by pressing the “R” key command. Then click on the pelvis to
select it (it becomes highlighted as below left). Position the cursor near the top of the
pelvis, hold the mouse button down, and move the cursor horizontally right.

Notice that the value in the X-box changes. Type “90” to make the pelvis horizontal (see
below right) then return it to its starting position. SHORTCUT: +/ (Mac) Alt+/ (Win).

Now let’s move the limbs.
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8.2 MOVING THE ARMS AND LEGS

Anatomically, the arms move at the shoulder joints and the legs move at the hip joints.
These are ball-and-socket joints that allow a great range of movement in many directions.

In DanceForms, to move the arms or legs, you move the Upper Arm or Upper Leg parts
highlighted below. The rest of the limb is carried along.

For example, when you move the Right Upper Arm, its Lower Arm, Hand and Fingers are
carried along.

If you try to use the mouse to move a finger or the hand, only the finger or the hand will
move.13

ADVISORY:
Using the mouse to move the limbs is quick but it is inaccurate. If you want to
specify body part positions precisely, type values in the X-, Y- and Z-boxes.

                                                
13 If you want to move a chain of parts, such as the whole arm from upper arm to fingertips, you can use
Inverse Kinematics (IK), described in the DanceForms 1.0 Reference Guide, page 68.
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8.3 MOVING AN ARM OUTWARD

To move the left arm outward to the left you click on the LUpperArm (it is highlighted),
then drag the limb outwards to about 45 degrees (hold the mouse button down, move the
mouse to the right, then release the button).

The Lower Arm, Hand and Fingers are carried along.

Notice that the Z-box value changes (48.51 in this instance). You may also notice that the
X- and Y-box values change if you drag upward or downward as you drag outward. You
need to move slowly and carefully when using the mouse to move a body part.

You can also move the arm outward or inward by clicking on the arrows to the right of the
Z-box value. Watch the arm move outward as the value increases (click on the up arrow

) and inward as the value decreases (click on ).

Try typing a value directly into the Z-box: double click on the number to select it (it is

highlighted  ), then type “90” to see the arm become horizontal:

To see the whole dancer in the window, make sure the STUDIO window is active, then
press the “A” key command (to show ALL).

To move the arm back to its neutral position, make sure it is highlighted then select Edit
menu > Reset to Default Shape. SHORTCUT: +/ (Mac) Alt+/ (Win).
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8.4 MOVING A LEG FORWARD AND BACKWARD

Change your view to side by pressing the “R” key command. First, select the leg you want
to move.

TIP: This can be tricky when two parts are superimposed, as in this side view. To select
the LUpperLeg, place your cursor over that part and hold the mouse button down until you
see a short list of parts in that area; release the button over LUpperLeg (it is highlighted).
Notice also that its name is displayed in the bottom right box of the STUDIO window.

Then drag the limb forward to about 60 degrees (hold the mouse button down, move the
mouse to the left, then release the button).

The Lower Leg, Foot, Arch and Toes are carried along. Notice that the X-box value
changes (62.34 in this instance). (Ignore the Y- and Z-box values for now.)

You can also move the leg forward or backward by clicking on the arrows to the right of
the X-box value. Watch the leg move forward as the value increases (  ) and backward as
the value decreases (  ). Then try typing a value directly into the X-box: double click on
the number to select it, then type -45 to see the leg become back oblique (as shown below):

To move the leg back to its neutral position, make sure it is highlighted then select Edit
menu > Reset to Default Shape. SHORTCUT: +/ (Mac) Alt+/ (Win).
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8.5 ROTATING THE LEGS

Change your view to Front by pressing the “F” key command.

To rotate the legs inward or outward, use the arrows or type a value directly into the Y-box.

Click on the RUpperLeg, then click on the  arrow until the Y-box value is 45 (see below
left).

The Lower Leg, Foot, Arch and Toes are carried along.

To get the same turnout on the other leg, select the Mirror command: click on the
LUpperLeg to select it, then press the +M (Mac) Ctrl+M (Win) key command. Notice
that the Y-box value is -45 (below right).

For paired body parts like the limbs, the Mirror command copies
information from the corresponding contralateral body part, then flips Z-
values (e.g., left/right) and Y-values (e.g., clockwise/counterclockwise) –
but not X-values (e.g., forward/backward).

For unpaired body parts like the torso and head, the Mirror command flips
Z-values (e.g., left/right) and Y-values (e.g., clockwise/counterclockwise)
on the selected part.

 

Notice that the Upper Legs each rotate around their own long axis.

To return the entire figure to its neutral position, double click anywhere on the dancer (all
parts are highlighted), then select Edit menu > Reset to Default Shape. SHORTCUT: +A,

+/ (Mac) Crtl+A, Alt+/ (Win).
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8.6 BENDING THE KNEES AND ELBOWS

The DanceForms dancer can bend her knees and elbows in impossible ways, but
anatomically knees and elbows are hinge joints capable of flexion and very slight
hyperextension.

For realistic animations, knee and elbow bends should be shown as changes in the X-box
values.

To watch the dancer bend her elbows or knees (X-box value changes), click on the small
dancer labelled Right to make it the main view.

To bend the left elbow, you need to move LLowerArm forward (see below left).

TIP: To select the LLowerArm, place your cursor over that part and hold the mouse button
down until you see a short list of parts in that area; release the button over LLowerArm (it
is highlighted and its name is displayed in the bottom right box of the STUDIO window).

Then either drag its bottom end forward or change the X-box value (click on the up arrow
or type a positive number directly in the X-box).

To bend the left knee, you need to move LLowerLeg backward (see below right). First
select the LLowerLeg (check the bottom right box in the STUDIO window to see that you
have selected the part you want), then either drag its bottom end backward or change the X-
box value (click on the down arrow or type a negative number directly in the X-box).

 

To return the entire figure to its neutral position, double click anywhere on the dancer (all
parts are highlighted), then select Edit menu > Reset to Default Shape.
SHORTCUT: +A, +/ (Mac) Crtl+A, Alt+/ (Win).
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8.7 POINTING AND FLEXING THE FEET

In the neutral position, the Foot, Arch and Toe parts are neutral (0).

Change your view to side by pressing the “R” key command. Select the LFoot directly on
the figure or from the Body Parts menu, then press the “S” key to make the part fill the
window. You can also zoom in or out by pressing and holding down the “Z” or “X” keys.

8.7.1 TO FLEX THE FOOT (below left)

To flex (dorsiflex) the ankle, you increase the X-box value (drag the end of the LFoot
straight upward, click on the up arrow beside the X-box, or type a positive number in the
X-box). TIP: Be sure to drag the end of the LFoot part NOT the LArch or LToe part.

To return the foot to neutral, press the +/ (Mac) Alt+/ (Win) key command.

             

8.7.2 TO POINT THE FOOT (above right)

To extend (plantarflex) the ankle, you decrease the X-box value for the LFoot (drag the
end of the L Foot straight downward, click on the down arrow beside the X-box, or type a
negative number in the X-box).

Do the same for the LArch and then the LToes.
TIP: (approximate values) Foot X = -60, Arch X = -10, Toes X = -20.

To make the right foot the same as the left, use the Mirror command: select RFoot from
the Body Parts menu, select All Descendants (the RFoot, RArch and RToes are
highlighted), then press the +M (Mac) Ctrl+M (Win) key command.

The All Descendants command is found near the top of the Body
Parts menu. Descendants are body parts distal (outwards) from
any part. The Arch and Toes are Descendants of the Foot.

To return the right and left Foot, Arch and Toes to neutral, select either Foot from the
Body Parts menu, select All Descendants (three parts are highlighted), then press and
hold down the Shift key as you Select Mirror also from the Body Parts menu (six parts
are highlighted).
Select Edit Menu > Reset to Default Shape, or type +/ (Mac) Alt+/ (Win).
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Exercise 9. Moving Body Parts in Combination

9.1 COMBINING UPPER AND LOWER ARM/LEG ACTIONS

Open “Exercise9.lfa”. From the neutral position, how would you move the left hand or foot
directly outward, bending at the elbow and knee? Remember that anatomically elbows and
knees are hinge joints; they cannot break over their side surfaces (see below).

   
L Lower Arm Z = 90; L Lower Leg Z = 90

OUCH!!

Anatomically, to move the hand outward without breaking the elbow joint, you need to
bend the elbow and rotate the upper arm. In DanceForms, you combine an X-box value
flexion of the Lower Arm X = 90 (shown below left) with a Y-box value rotation of the
Upper Arm Y = -40 (shown below right). The same principle applies for the Upper and
Lower Leg.

    
L Lower Arm X = 90 plus L Upper Arm Y = -40
L Lower Leg X = -90 plus L Upper Leg Y = 40

To view a position from a different angle, click on the small dancer at the right side of the
STAGE window to make it the main view. View Resa from the side, front and top.

TIP: If you want to store a new position as you change it in the STUDIO, click on  in
the PANEL to advance to a new frame. Each new body keyshape is set in the SCORE
every time you move to a new frame.
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9.2 CREATING COMPLEX ARM AND LEG POSITIONS14

Using the principles covered above, how would you create this position?

9a: a fist on the hip

TO COMPOSE A SIMPLE POSITION, START FROM THE NEUTRAL POSITION:
BEGIN BY MOVING PARTS FROM THE OUTER END AND WORK INWARD.

9.2.1 Exercise 9a: a fist on the hip

1. Starting with the dancer in neutral position, first curve the fingers. Start from the
outermost end (e.g., Index3) and work inward (Index2, Index1, for each finger)
until you have a fist (ignore the thumb for now).
TIP: For small body parts, it is best to select a part from the Body Parts menu
rather than by clicking directly on the figure. The outermost parts of the finger are
hinge joints. From the starting position, curve the fingers inward by moving the
finger segments, changing the X-box value only. To see a small body part clearly,
type “S” and the selected part will fill the window. To zoom in or out, press and
hold down the “Z” or “X” keys.

2. Bend the elbow.
TIP: Do the position yourself to estimate how bent the elbow must be (i.e., more
than 90 degrees but less than 180 degrees)

3. Move the upper arm outward (Z) then backward (X) to where you estimate your
own arm position would be – without any rotation.

4. Rotate the upper arm inward (Y) to place the fist on the hip.
If needed, fine-tune the position by clicking on the arrow keys for the upper and
lower arm segments.

                                                
14 A great range of positions is stored in palettes on the Ballet Moves and Modern Dance Moves CD-ROMS.
This exercise explains how they were created so you can make your own positions or refine the palettes.
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9.2.2 Exercise 9b: ballet retiré

1. Point the foot by changing the X-box values for the Toes, Arch and Foot parts.
TIP: Experiment until you like the curve of the foot.

2. Bend the knee (about 120 degrees).
3. Move the upper leg outward (Z) and just in front of the body (X), estimating where

your thigh would be – without any rotation.
4. Rotate the upper leg outward (Y) to place the toe near the knee.

TIP: Anatomically, turnout is about 60 degrees from the thigh.
If needed, fine-tune the position by clicking on the arrow keys for leg parts.

5. Position the arms and place the supporting leg below the pelvis to balance the
dancer (giving the illusion of a pelvic shift as described in Exercise 5; more soon).

TO MAKE LARGE ADJUSTMENTS TO A BODY PART POSITION, YOU CAN USE
THE MOUSE OR THE GLOBES.

TO MAKE FINE ADJUSTMENTS TO A BODY PART POSITION, IT IS BETTER TO
USE THE ARROWS OR TYPE VALUES INTO THE X-, Y- OR Z-BOXES.

TO CHANGE A BODY PART POSITION IN THE LATERAL OR SAGITTAL PLANE
ONLY, YOU MUST:

1. CHANGE THE Y-BOX VALUE TO “0”,

2. USE THE ARROWS TO CHANGE X- OR Z-VALUES ONLY,
(click on the arrow once; if the part “jumps” use Undo to return it to the original
position and continue clicking on the arrows until you get the desired position), THEN

3. RE-ENTER THE Y-BOX VALUE TO RESTORE THE TURNIN OR TURNOUT.
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9.3 MORE LIMB POSITIONS AND MOVEMENTS

The shoulder and hip joints are called ball-and-socket joints.
They allow complex combinations of flexion, rotation, abduction, etc.

To see this, select the RUpperArm, then click anywhere in the globe at the top left of the
STUDIO window. The dancer’s right arm assumes the same orientation as the coloured
line in the globe.

Click at a few other spots in the globe and notice that the X, Y and Z-box values change,
corresponding to the change in the arm position.

The top globe controls and reflects changes in orientation FAR from the viewer (behind the
dancer in the Front view).

The bottom globe controls and reflects changes in orientation NEAR to the viewer (in front
of the dancer in the Front view).

Click on a small figure to change the view, then click again in each globe to see how they
relate to (control or reflect) the dancer’s arm position.
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9.4 POSITIONING THE PELVIS FIRST

When you become familiar with moving each limb, begin to explore more complex
interconnected positions. This is particularly challenging when the pelvis is not in its
neutral position, as for example in a ballet arabesque.

FOR POSITIONS WHERE THE PELVIS IS NOT IN ITS NEUTRAL POSITION, IT IS
BEST TO POSITION THE PELVIS FIRST, THEN WORK OUTWARD TO ADJUST
THE TORSO AND POSITION THE LEGS AND ARMS.

9.4.1 Exercise 9c: ballet arabesque
1. Position the pelvis by tilting it forward (negative X-box value).
2. Erect the torso by counter-tilting the Chest&Waist and Chest segments (positive X-

box values).
3. Position the supporting leg under the centre of weight by repositioning the

RUpperLeg and RFoot to make sure the sole is flat on the floor.
4. Then position the lifted leg directly behind its hip, and point the foot.
5. The same principle applies to upper torso positions in which the spine and shoulder

girdle come into play. First position the trunk, then work outward from the
shoulders through the arms to the hands.

6. Positioning the fingers can be tricky. The great number and small size of the finger
segments make it best to position them in relation to the neutral body, then Copy
the hand position and Paste in onto your arabesque.
TIP: Advance to a new frame, then return the dancer to the neutral position: in the
STUDIO window, Select All body parts, then select Edit menu > Reset to Default
Shape. Position the hands and fingers. Drag across that frame in the SCORE
window and Copy it. Double click on the frame showing the arabesque to open its
STUDIO window. Select both Hands and All Descendants, and Paste the hand
positions onto the arabesque position.
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This is a challenging exercise that makes use of all of the techniques outlined in this
section. There is no one correct way to solve it. The skill comes in knowing which
technique to use to position each body part.

TIP: For example, once you have positioned the pelvis, supporting leg and upper torso, it is
easy to position the lifted leg parallel to the ground and directly behind its hip joint by
using the globes. Notice how the dark line in the Near globe below represents a horizontal
thigh at right angles to the body.

To change the amount of thigh turnout, you need to type a value directly into the Y-box.

To see Resa perform one set of solutions for the positions in this Exercise, open
Exercise9CombinedPositions.lfa.
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9.5 “TWEENING” POSITIONS

You can make subtle adjustments to body keyshapes by using DanceForms automatic
“tweening”.

9.5.1 Exercise 9d: halfway positions

For example, let’s create a half turned out retiré, based on the ballet retiré in Exercise 9b.
Open Exercise9CombinedPositions.lfa and select the retiré keyframe in the SCORE (drag
across to make a rectangle surround the frame as below left. Then Copy and Paste the
selected keyframe in the next frame (before you Paste, make sure to select Edit menu >
Paste Defaults: √Absolute Location √Absolute Facing).
The SCORE now looks like below right:

                            
Double click on the Pasted frame to open its STUDIO window, then change the dancer’s
legs to a parallel retiré position.

TIP: For neutral leg rotation (neither turned in nor turned out), change both UpperLeg
values to Y=0, then use the globes to reposition them. Or return both thighs to the starting
position (select RUpperLeg + LUpperLeg, then Edit menu > Reset to Default Shape) and
move the RUpperLeg forward (about X=80, see below left). Look at the position from the
Front view to adjust the supporting leg below the pelvis (see below right). You will also
need to reposition the supporting foot (select LFoot, Edit menu > Reset to Default Shape).
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Now click between the two retiré positions in the SCORE to get an insertion point (a
vertical line NOT a rectangle) and press the spacebar to add a new frame. When you double
click on the empty frame to open its STUDIO window, you will see that DanceForms has
tweened a half turned out retiré position.

  
keyshape: turned out “tweened” half turned out keyshape: parallel

TIP: By default, DanceForms uses Linear interpolation (Figure menu > Shape
Interpolation > Linear) to calculate transitional positions exactly halfway between
keyframed information. It automatically “tweens” a half turned out retiré.

To get a retiré slightly more or less than half turned out, add more new frames.
The more new frames you add between keyframes, the more subtle the changes.

Just click on   (Mac)   (Win) to step through the empty tweened frames
until you find the position you want.

To turn a “tweened” shape into a body keyshape, drag across to select the frame in the
SCORE, then select Edit menu > Key Frame > Shape (or All to set all attributes).

To see Resa perform one set of solutions for all positions in this Exercise, open
Exercise9TweenedPositions.lfa.
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Exercise 10. Using Palettes of Keyshapes

10.1 USING CUSTOMIZED PALETTES OF DANCE POSITIONS

DanceForms makes it easy to use predefined palettes for codified positions in ballet or
well-known positions in modern dance. Sets of customized palettes are included in the
Ballet Moves and Modern Dance Moves CDs that come with DanceForms 1.0.

Basic palette techniques were introduced in PART A.15 A brief overview follows below.

10.1.1 To begin, open Exercise10.lfa and Exercise10.lfp (select Edit menu > Open… Be
sure to ). Or choose from the list below the Animation  or
Palette  icons (Mac), or the Animation or Palette menu items (Win).

10.1.2 To add a new frame to your SCORE with a whole body position from the
Palette, click in the SCORE to get an insertion point (you see a vertical line NOT a
rectangle), then click quickly and lightly on the Palette position you want. If you click too
slowly and a menu appears, drag until Assume is highlighted and release the mouse button.
A new frame with the selected keyshape is added to the SCORE.

Insertion point: Palette Position 1:  New frame added to SCORE: 

10.1.3 To change only a body keyshape in a frame already in the SCORE, drag across
the frame in the SCORE to select that frame (you see a rectangle NOT a vertical line), then
click quickly and lightly on the Palette position you want. This technique updates only the
body position and does not affect information specified for the Location, Altitude, Facing
or Snap.

Frame 1 selected: Palette Position 2:  Frame 1 Keyshape changed: 

10.1.4 To change only part of a body keyshape in a frame already in the SCORE, drag
across one frame in the SCORE to select it (you get a rectangle NOT a vertical line), then
click anywhere in the STUDIO to activate that window or double click on the frame in the

                                                
15 For an overview of Palettes, see Chapter 15 of the Life Forms 4.0 User Guide/DanceForms 1.0 Reference.
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SCORE to open a new STUDIO window. Click directly on the body part or parts you want
to update (their colour becomes more vivid), then click quickly and lightly on the Palette
position you want. Only the body parts you have selected will assume that Palette position.
This technique is useful for changing only the arm positions, for example:

1. 2. 3. 4.  5. 

1. Select Frame 1 in the SCORE.
2. Select the arms and head in the STUDIO (see TIP 3 below for a shortcut)
3. Click on Palette position 1.
4. Arms and head in the STUDIO assume the Palette position.
5. Frame 1 in the SCORE shows the updated position (legs from Palette position 2 with

the arms and head from Palette position 1).

TIP 1: You can select multiple body parts by clicking on the dancer in the STUDIO while
holding down the Shift key to extend your selection. For example, click on the RUpperArm
(it becomes vivid), then hold down the Shift key as you click on the LUpperArm (both
parts are vivid).

TIP 2: You can also select parts from the list on the Body Parts menu. To see the menu,
position, your cursor in the STUDIO window near the dancer, then hold down the mouse
button until the Body Parts menu appears. In the Win version, the menu stays open when
you release the button, and closes when you select a part or click in the STUDIO. To keep
the menu open in the Mac version only, place your cursor to the right of the dancer in the
STUDIO, press and hold down the mouse button, drag left of the dancer, then release the
button. To close the menu, click in the Close box at the upper left.

The Body Parts menu is useful for selecting several parts at once, e.g.:
• the upper body (Chest + All Descendants)
• a whole arm (RShoulder + All Descendants)
• a whole hand (RHand + All Descendants)
• both legs (RUpperLeg + All Descendants + Select Mirror)
• the torso and head (Head + All Ancestors), etc.

TIP 3: If you want only the arms and head, select Upper Chest and hold down the Shift key
while selecting All Descendants in the Body Parts menu.

TIP 4: If you want to update everything except the head position, double click on the
figure to select the whole body, then hold down the Shift key as you click on Head and
Neck&Head to deselect only those parts.

Explore how you can select various combinations from the Body Parts menu, with and
without holding down the Shift key.
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10.2 CREATING YOUR OWN PALETTE OF DANCE POSITIONS

DanceForms makes it easy to store positions that you have created yourself or found in
customized libraries. You can organize these positions into sets of palettes that share
characteristics or that embody movement concepts or styles. From these, you can build
combinations with unique qualities.

10.2.1 To create a palette from an existing animation, open the sequence you completed
in Exercise 9 or 10, or open the sample Exercise9CombinedPositions.lfa.

1. Select Scripts menu > Dancer to Palette. An Untitled Palette appears (see below left),
displaying the body keyshapes from the animation. To explore how you can change the
View, Size and Drawing Style of the Palette, position your cursor on the triangle  near
the top right of the Palette, press and hold down the mouse button as you drag downward,
then release the button when the selection you want is highlighted.

2. To name each keyshape, open the Palette Editor (Window Menu > Palette Editor). Click
below each position and type a descriptive label (see below centre). When you click outside
the text area (Mac) or click Update (Win), the name will appear below each keyshape.

3. To make the label appear in the Palette itself (see below right), make sure that a check
mark precedes √Show Names below the triangle .

1.    2.    3. 

4. To save the Palette only, first close the Palette Editor and its STUDIO window if it is
open (NOT the STUDIO window for Exercise9CombinedPositions.lfa). When you Close
the Palette itself, a dialogue box appears. Click Save As, type a name for the Palette, then
click OK. Or select Edit menu > Close All to get a dialogue box for the palette.
To save your palette and all animations currently open, select Edit menu > Save All.
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10.3 REFINING PALETTE POSITIONS

To refine the body position for a keyshape already stored in a Palette, there are three
basic techniques. You can of course Undo unwanted changes and Save ones you like.

1. To replace the whole position: Open the Palette and the animation containing the
position you want. Click above a frame in the SCORE to select it (a red vertical line bisects
the frame), then position your cursor on the Palette position you want to update. Press and
hold down the mouse button as you drag downward to select Update Palette. The position
from the SCORE appears in the Palette.

You can also update a Palette position by activating the STUDIO window containing the
position you want, then selecting Update Palette on the keyshape you want to replace.

2. To replace only part of a position: Open the Palette and the animation containing the
position you want. Select and Copy the frame you want from the animation SCORE. Open
the Palette Editor (Window menu > Palette Editor), double click on the key shape you want
to change to open its STUDIO window, then select the parts you want to replace (their
colour becomes more vivid, see Tips 1-4 in section 10.1 above). Select Edit menu > Paste.
The position you Copied replaces only the selected parts in the STUDIO, the Palette Editor
and the Palette itself.

3. To make new changes: Open the Palette, then open its Palette Editor (Window menu >
Palette Editor). Click on the position in the Palette Editor to activate the corresponding
STUDIO window and reposition the figure. If you don’t like the changes you have made,
you can restore the position by selecting Edit menu > Revert. Any changes you make will
be saved as soon as you move to another keyshape or to a new frame in the Palette Editor.

4. To undo changes: If you do not like a change you made to a Palette position, select Edit
menu > Undo to undo only the last change, or Edit Menu > Revert to return to the stored
Palette position (i.e., the last saved Palette position). Revert does not work after you leave
the current keyshape (i.e., once you click on any other keyshape in the Palette Editor).

5. To save changes: When you are satisfied with your updated Palette, first close its Palette
Editor window and its STUDIO window if they are open. When you close the Palette itself,
you will be prompted to Save As…. Then type MyExercise10.lfp and click OK.

For an example, continue on to Part C. Exercise 11.
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PART C:
Creating with Ballet Moves and

Modern Dance Moves

These Exercises introduce DanceForms features you can use to create dance
combinations, enchaînements and choreography from libraries of ballet and modern

dance palettes and animations.

Exercise 11 Refining the Body Line of Positions:
Changing the Look of Positions to your Personal Taste

Exercise 12 Creating Combinations or Enchaînements:
Linking Steps into Sequences

Exercise 13 Repeating Sequences on the Same or Other Side:
Mirroring Positions, Facings and Paths

Exercise 14 Changing Body Alignment:
Setting Facing Angles

Exercise 15 Adding the Head and Arms:
Port de Bras and Torso Actions

Exercise 16 Dancing to the Music:
Adding Sound, Changing Frame Rate and Tempo;
Suggesting Dynamics

Exercise 17 Adjusting Paths Across the Floor:
Learning Other Dancers’ Steps and Adding More Dancers
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Exercise 11. Refining the Body Line of Positions:
Changing the Look of Positions to your Personal Taste

11.1 Ballet Moves and Modern Dance Moves are libraries of palettes and animations you
can use as a basis for visualizing and chronicling choreography. Ballet Moves contains sets
of palettes based mainly on the Russian and English “schools” of classical ballet. Modern
Dance Moves palettes are based on mid-twentieth-century American modern dance. Each
Dictionary of steps and movements is “built” from the corresponding set of palettes. You
can easily change Dictionary palettes to build your own personal set. Simply:

• open the palette you wish to change,
• edit the palette using the guidelines introduced in Exercise 10, and
• save it under a new name.

11.2 For example to change the look of the 1st arabesque found in BasicPositions.lfp:

1. Open the palette, then open its Palette Editor (Window menu > Palette Editor). It
appears at the bottom of the screen and looks similar to the SCORE window.

TIP 1: Unlike the SCORE, you cannot “play” the Palette Editor or use the Panel to
navigate from position to position. Instead, use the scroll bar at the bottom of the Palette
Editor window to find the keyshape you want to work on, then click directly on it.

2. Click in the Palette Editor on the arabesque you want to refine.

3. The dancer appears in the Palette’s STUDIO window, performing the position.
You can now edit it.

TIP 2: If you have an animation open, take care to edit the position in the STUDIO
window corresponding to the Palette NOT the animation (i.e., .lfp versus .lfa).

TIP 3: To refine palette positions, you can use any of the techniques introduced in PART B
except “tweening”. To use “tweening” you must open an animation and set two similar
keyframes in the SCORE window so that DanceForms can “tween” a halfway position, etc.

TIP 4: Be sure to view positions from all angles. If you don’t like changes you have made
and want to cancel them, select Edit menu > Revert before you click on another position.

 
Ballet Moves BasicPositions.lfp My Personal Palette:

1st arabesque 1st arabesque
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TIP 5: Undo and Revert are similar but distinct features. Select Edit menu > Undo to undo
only the last change. Select Edit Menu > Revert to return to the stored Palette position (i.e.,
the last saved Palette position). Revert does not work after you leave the current keyshape
(i.e., once you click on any other keyshape in the Palette Editor).

The Ballet Moves arabesque shown above left depicts an academic “squared” arabesque.
The revised arabesque shows a higher working leg (see below, LUpperLeg X = -62.52, Y =
-45, Z = 35.12), more turned out supporting leg (RUpperLeg Y = 45), more arched upper
back (Upper Chest X = 30), and more open back arm (LShoulder Y = -30).

4. Continue making refinements to any palette position until you are satisfied, then
close the Palette’s STUDIO and Palette Editor windows. When you close the
Palette itself, you will be prompted to Save As… under a name you choose.

11.3 Next, try refining some positions from palettes in Modern Dance Moves. To review:

1. Open the palette, then open its Palette Editor (Window menu > Palette Editor).

2. Use the scroll bar at the bottom of the Palette Editor to locate the position you
want, then click directly on the keyshape you want to refine.

3. Edit that position on the figure in the STUDIO window.

4. Continue editing positions as you like, then close the Palette STUDIO window, the
Palette Editor window, and finally the Palette. When prompted, Save As… under a
new name of your choice.

Dance phrases you build with your personal palettes will have their own distinctive look.
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Exercise 12. Creating Combinations or Enchaînements:
Linking Steps into Sequences

12.1 You can use the DanceForms Dictionaries to create your own enchaînements or
combinations and choreography. Simply:

• open the Waiting Position for the dancer you want (Rose, Resa, Ben or Jacques),
• open the step you want from the Dictionary (keep your own file open), and
• Copy the step from the Dictionary and Paste it into your personal file.

12.2 For example, to create an Allegro enchaînement with soubresauts and changements:
Open RoseWaiting.lfa, then save it under a new name, e.g., File menu > Save
As…MyAllegro.lfa.

1. Open Soubresaut.lfa. This example is based on the Ballet Moves Dictionary. Watch the
jump or look in the SCORE to see where it starts and ends (beginning with right foot
front).16 Note that the frame rate is 6fps (frames per second). Then Select and Copy the
frames containing the soubresaut (frames 2-13) (see TIP 1). The information in these
frames is stored on the DanceForms Clipboard. Close that file (don’t save changes).
TIP 1: Before you Copy a sequence from the Dictionary, it is good practice to make the
first and last frames keyframes, if they are not already. In the SCORE select the first
frame to be Copied, then select Edit menu > Key Frame > All. Repeat for the last frame
to be Copied. This sets the start and end Keyshape, Facing, Location, Altitude and Snap
so that unexpected changes do not appear when you Paste the sequence into your file.

2. Paste the Copied frames into the SCORE of MyAllegro.lfa.
TIP 2: Before you Paste a sequence into your personal file, make sure to check the
correct Paste Defaults (Edit menu). If you don’t want the dancer’s Location or Facing
to change, make sure that a check mark precedes √Absolute Location and √Absolute
Facing. If you want the dancer’s Location and Facing to continue from the last ones
specified, make sure that a check mark precedes √Relative Location and √Relative
Facing. Deselect Comment Pastes if you don’t want a text Note showing the original
file name.
TIP 3: When you Paste a sequence from one file to another, DanceForms tries to
preserve the timing. For example, when you Paste the 12-frame sequence from
Soubresaut.lfa (6fps) into your personal file (3fps), it asks, “Do you want to change the
frame rate to match the source?” For now, select “Don’t change” to keep your file 3fps.
The 12-frame jump sequence takes 2 seconds when played at 6fps but 4 seconds when
played at 3fps with the triangle centred in the PANEL. You can change the playback
speed by sliding the triangle in the PANEL to show a faster or slower tempo.
When you add music or a metronome beat, however, you may need to change the frame
rate. More on timing in Exercise 16.

                                                
16  The DanceForms Dictionary presents steps first with the right foot starting front and again with the left
foot starting front. As you watch an entry you may notice that transitions appear unreal when they are
intentionally unspecified. The feet appear to slide through one another in transitions from 5th to 5th. For more
information see the Read Me file on the Ballet Moves and Modern Dance Moves CD.
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To Paste the jump after Rose’s Waiting Position, click above Frame 2 in the Score to
get an insertion point after Frame 1. To replace Rose’s Waiting Position with the
starting position, 5th position bras bas, drag across Frame 1 in the SCORE, then select
Edit menu > Paste.
The SCORE looks like this:

3. To add a changement, open Changement.lfa. Watch the jump or look in the SCORE to
find where the changement begins and ends, starting right foot front. Select and copy
the frames showing the whole jump from preparation (5th R ft fr) to landing (5th L ft fr)
as in the sequence labelled changement, below right. Don’t forget to make the first and
last frames keyframes before you Copy them if needed (see TIP 1). Then close the file.

4. To return to your file if needed, select Window menu > MyAllegro.lfa (or your file
name) > All Windows. Paste the copied frames into the SCORE of MyAllegro.lfa.
Then to make the soubresaut and changement continuous, remove any extra frames, etc.
(drag across unwanted frames in the SCORE, then select Edit menu > Cut), e.g.:

  
The landing for the soubresaut leads into the push-off for the changement.
TIP 4: Be careful not to delete a frame that contains important keyframe information
for altitude . (Remember that you can undo an unwanted action by selecting Edit
menu > Undo). If you delete an important altitude keyframe, you may see Rose float off
the ground when she should not. To keep Rose contacting the floor on the push-off and
landing frame for each jump, check that her altitude is “0” (see Exercise 3). You can
make each jump as high as you like by increasing the altitude at the height of the jump
(in the STAGE window).
TIP 5: Remember, when you enter an altitude in the STAGE window, the value is
displayed below the corresponding frame in the SCORE. As the SCORE window gets
smaller, the altitude icon replaces the value.

By Cutting and Pasting you can change the enchaînement to show different combinations,
e.g., three soubresauts and one changement.
Remember to save your enchaînement. To see a sample, open Exercise12Example.lfa.
If you want to repeat the whole enchaînement on the other side, continue on to Exercise 13.
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Exercise 13. Repeating Sequences on the Same or Other Side:
Mirroring Positions, Facings and Paths

13.1 You can easily make your dancer repeat each step or the whole enchaînement or
combination. Simply:

• Copy the step you want to repeat, then Paste it as many times as needed, Cutting
out any unwanted frames to make the action continuous (see Exercise 12), and/or
• make the dancer perform a position or a sequence on the other side by using the
Mirror feature.

13.2 To repeat your Allegro enchaînement, continue working on your file or open
Exercise12Example.lfa:

1. Select the entire sequence in the SCORE, Copy it, click to get an insertion point after
the first sequence, then Paste it (remember to check Paste Defaults and set keyframes).
Watch the sequence and notice that each sequence begins with the right foot front but
ends with the right foot back.

|                                                                       | |                                                                    |
first sequence second sequence
2. To make Rose perform the second sequence on the other foot, drag across to select it, then

select Edit menu > Mirror. A large dialogue window appears. Make sure a check mark (√)
precedes Shapes  (click in an empty box to add a
check mark, or click in a check marked box to remove it). For now disregard other choices.
To preview what will happen when you Mirror, click on the green arrow at the bottom left
of the Mirror window. To complete the action, click on the Mirror button.
TIP 1: This particular sequence is done facing front without travel. If the pattern you want
to repeat contains changes in Facing, Location and Snap, you will also need a check mark
(√) preceding those items. For details, see DanceForms 1.0 Reference Guide, Chapter 6.
TIP 2: To Mirror a part or all of one body keyshape without changing the Facing, Location
or Snap, you can simply select the body part or parts in the STUDIO, before selecting Edit
menu > Mirror. Only the selected parts are mirrored. To Mirror the entire body keyshape,
Select All body parts in the STUDIO. This technique works only for one frame at a time.
To Mirror a series of frames, it is faster to select them in the SCORE.

3. Remove unwanted frames to make the two sequences continuous:

Save your file as MyExercise13.lfa, or see Exercise13Example.
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Exercise 14. Changing Body Alignment:
Setting Facing Angles

14.1 You can make an enchaînement or combination face any direction you like. Simply:

• set a facing angle at the start of the sequence, then
• reset the same facing angle to keep the dancer facing the same way, or
• set a new facing angle to make the dancer change gradually between two facing
angles.

14.2 Continue working on your enchaînement, or open Exercise13Example.lfa. When no
facing angle is specified, the dancer faces Front (Audience). The Allegro enchaînement you
created in Exercise 13 is done en face. To make it start and end facing a downstage corner,
croisé, you need to specify facing angles:

Facing: Angle (in positive degrees): Angle (in negative degrees):
Front (Audience) 0 or 360 0 or 360
Downstage Right 45 (40*) -325 (-320*)

Stage Right 90 -270
Upstage Right 135 (130*) -235 (230*)
Upstage (Back) 180 -180

Upstage Left 235 (230*) -135 (130*)
Stage Left 270 -90

Downstage Left 325 (320*) -45 (-40*)

*To get a better body line for ballet, the angle is slightly flatter than halfway between front and side, etc.

|                                          | |                                     | |                                       | |                                     |
first soubresaut first changement second soubresaut second changement

Watch the entire sequence to decide when the dancer should face a downstage corner.

1. To begin en croisé (facing Downstage Left), click above the starting frame for the jump
sequence in the SCORE. Open the STAGE window: +L (Mac) Ctrl+L (Win). Click
on Rose to make her controls appear near the top left of the STAGE window, then type
320 or -40 in the box beside the facing icon . Look at Rose’s Figure Status grid

 in the STAGE window. Notice that the each icon appears in the grid and
also in the SCORE below the body keyshape.

In the PERFORMANCE window you can see that Rose now starts croisé.

       Facing 0° (en face):       Facing (en croisé): -40° (320°): 
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Watch the entire sequence again and notice that Rose gradually changes from croisé to
en face. To understand why, look at the Facing angles in the starting position (320)
versus the end frame (0).
TIP: Remember, when you enter a facing angle in the STAGE window, the angle is
displayed below the corresponding frame in the SCORE. As the SCORE window gets
smaller, the facing icon  replaces the angle value.

2. To keep Rose facing Downstage Left until the landing of the first soubresaut or the
push-off for the first changement (Frame 10), reset a value of 320 in the STAGE
window for that frame.

3. To make Rose face Downstage Right by the landing of the first changement, set a value
of 40 in the STAGE window for that frame (Frame 17). Watch the sequence and note
that Rose’s facing angle changes gradually during the jump.

4. To keep Rose facing Downstage Right until the landing of the second soubresaut or the
push-off for the second changement, reset a value of 40 in the STAGE window for that
frame (Frame 24).

5. To make Rose face Downstage Left by the landing of the second changement, set a
value of 320 in the STAGE window for that frame (Frame 31). Her facing angle
changes gradually.

6. To keep Rose facing Downstage Left, ending the sequence croisé as it began, reset the
facing of the final frame to 320. The SCORE looks like this:

|                           |                                                                                          |                                                                                            |___
plié first soubresaut first changement

Step #1 #2 #3

                                                                                          |                                                                                                |                              |
second soubresaut second changement restretch

#4 #5 #6

You can watch your enchaînement in the STAGE or PERFORMANCE window.

TIP: To keep a dancer facing the same direction over a series of frames, set the same
facing angle for the first and last frame in the series. To change facing, set a new facing
angle. The more frames between the original and new angle, the more gradual the change
in facing; the fewer frames between, the more abrupt the change.
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Exercise 15. Adding the Head and Arms:
Port de Bras and Torso Actions

15.1 You can add head, body or arm movements to an enchaînement or combination.
Simply:

• Copy a movement from the Dictionary animation libraries, and
• Paste it into your personal files using the Paste Special feature.

15.2 For example, to add a basic port de bras to your Allegro enchaînement, continue
working on your file, or open Exercise14Example.lfa. Next:

1. Open the BasicPortdeBras.lfa (based on the Ballet Moves Dictionary, English School),
and keep your own file open. Watch the action or look in the SCORE to find where the
sequence starts and ends. Then Select and Copy the 17 frames containing the basic port
de bras (remember to make the first and last frames keyframes before you Copy them if
needed). The information in these frames is stored on the DanceForms Clipboard. Close
the file.

TIP: If needed, you may leave more than one animation open at a time. To switch
quickly between animations, just select Windows > “animation name” > All Windows.

2. The soubresaut-changement combination is 33 frames long. Select the entire
enchaînement in the SCORE:

3. To Paste the movements you Copied from the Dictionary BasicPortdeBras.lfa into the
upper body of your personal enchaînement:
3.1 Select Edit menu > Paste Special….
3.2 Click in the box preceding Selected Joints (see illustration below).
3.3 Deselect all other attributes since you want to Paste only body keyshape
information. A checkmark now precedes only √Shapes and √Selected Joints. Disregard
the Frame Rate selection for now. (See illustration below.)
3.4 The BasicPortdeBras.lfa is performed in 5th position. To Paste information into the
upper body of your personal enchaînement without changing the jumping action of the
legs, select Upper Body from the menu to the right of Selected Joints. Notice that those
parts are highlighted on the dancer at the right of the Paste Special window.

TIP: You may also select body parts in the Paste Special window by clicking directly
on the dancer or by using the Body Parts menu (see Exercise 7).
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Notice that Adjust Clipboard is selected by default in the Paste Special window.
If the frame rate is different in the Dictionary file and your personal file, and Adjust
Clipboard is selected, DanceForms will adjust the frame rate on the Clipboard to
coincide with your personal file. If Adjust Destination is selected, DanceForms will
compress or expand your personal file to preserve the relative timing.

4. To preview what will happen when you Paste, click on the green arrow at the bottom
left of the Paste Special window. When you are ready to complete the action, click on
the Paste button. The SCORE looks like this:

DanceForms adds the information from the Dictionary file you Copied to the frames you
highlighted in your personal file. The Dictionary movement is 17 frames long but your
Allegro enchaînement is 33 frames long. DanceForms automatically distributes the 17-
frame-movement across 33 frames to preserve the relative timing
(see Exercise15Example1.lfa).
TIP 1: When you Paste upper body movements from the Dictionary into your personal
file, be sure to specify only the parts you wish to Paste. In the Allegro enchaînement we
used, the pelvis was in a neutral position throughout. Most enchaînements involve
movements of the pelvis and counter-adjustments in the body (Chest&Waist, Chest and –
for high leg extensions – UpperChest). To prevent unwanted changes in the body of your
dancer when you add a port de bras and head movement, it may be sufficient to select
only the arms and head in the Paste Special dialogue box (select UpperChest, then hold
down the Shift key as you select All Descendants).
TIP 2: You may want to Paste shorter sequences of the port de bras to coincide with
each jump: Copy Port de Bras Frames 1-4 (bras bas to 1st) into your file Frames 1-10.

Copy Port de Bras Frames 4-9 (1st to 2nd) into your file Frames 10-17.
Copy Port de Bras Frames 9-17 (2nd to bras bas) into your file Frames 17-33.

(Note that frame numbers overlap because the last frame of one port de bras is the first frame of the next.)

For a sample, see Exercise15Example2.lfa.
TIP 3: You can change part or all of a body position one frame at a time in the
DanceForms STUDIO. To change part or all of a body keyshape across a series of
frames in the SCORE, it is easier to use Paste Special.
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Exercise 16. Dancing to the Music:
Adding Sound, Changing Frame Rate and Tempo; Suggesting Dynamics

16.1 You can add music or a metronome beat to your compositions by using the Sound
feature.

• Open the Sound file you want from the Sound menu
• Change the frame rate of your personal file to set the tempo if needed
• Add or delete frames to make the movement fit the sound
• Compress or expand parts of the movement to suggest movement qualities

16.2 For example, let’s add a metronome beat to your Allegro enchaînement. Before we get
started, save only the four-jump sequence you created in Exercise 15 under your own
name, e.g., MyExercise16.lfa. To provide landmarks for the phrase, you may want to label
the first frame of each bar (each demi-plié landing). Or you can open Exercise16.lfa.
The SCORE looks like this:

1. To add a metronome beat, select Sound menu > Sound File… > Choose >
1bps60bpm.aif. Click Convert, then OK. The metronome sounds one beat per second
or, in musical terms, 60 beats per minute. Watch the combination at various speeds.
TIP: To speed up the tempo, drag the triangle pointer in the PANEL toward the hare
icon. To slow it down, drag the pointer toward the tortoise icon. Notice that the dancer
performs the combination faster or slower as you change the triangle position. The
metronome beat, however, is constant.

2. You can also change the tempo of your enchaînement by changing the frame rate.
2.1 First, set the triangle pointer to the centre of the PANEL,17 and watch the
enchaînement. It looks very sluggish. Initially, all DanceForms files are set at three
frames per second. Each jump in this enchaînement takes seven frames at three frames
per second – over two seconds – much too slow for an Allegro quality.
2.2 To pick up the tempo, we’ll increase the frame rate. Select Control menu > Frame
Rate…, then change “3.00” to “7.00”. Click OK. Watch the enchaînement and note the
faster tempo (7 frames or 1 metronome beat every second). Note also how the
movement corresponds to the metronome beat.
2.3 Add new frames after the starting position if needed to make each demi-plié landing
correspond to a metronome beat

The rest of this exercise explores musical time signatures and explains how to make subtle
adjustment to the timing of your composition that changes the quality of the movement.
                                                
17 When you Export a DanceForms file to another application, the enchaînement or combination is exported at
the specified frame rate, as if the triangle is set to the centre of the PANEL. When working with Sound files,
it is best to centre the PANEL triangle and alter the tempo by changing the frame rate.
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3. Let’s set the enchaînement to a quick 2/4 rhythm, one jump per bar, landing on the first
beat of each bar. As dancers, we may count this four-bar enchaînement:“1, 2, 2, 2, 3, 2, 4,
2” or “1, &, 2, &, 3, &, 4, &” (each boldface number shows count 1 of each bar,
corresponding to the landing; “&” is really count 2, corresponding to the aerial
position). We’ll use a metronome beat that sounds twice per bar.
For 2/4 rhythm, it helps to use an even number of frames per jump, so that the action
can be divided into halves and quarters. For example, let’s change this enchaînement:
3.1 Select a faster frame rate: Control menu > Frame Rate… then enter “12.00” fps.
3.2 Add a quick metronome beat: Sound menu > Choose > 1.5bps90bpm.aif. This will
give one metronome beat every 2/3 second, corresponding to each landing.
3.3 Make each jump take an even number of frames, i.e., 8 (8/12 or 2/3 of a second).
To change each jump from 7 to 8 frames, try adding a frame at various places in the
push-off, aerial phase and landing. Note how changing one frame alters the quality of
the jump. For example, adding an extra frame in the push-off makes the jump look
heavy and laboured.
3.4 To create an even jump, add the extra frame in the aerial phase (4 frames in air, 4
on ground):

3.5 To cushion the landing, delete the extra aerial frame and add a new frame before
each plié (3 frames in air, 5 on ground):

3.6 Save your enchaînement as My Exercise16Allegro2/4.lfa.18

3.7 If you like, open Exercise16Example2/4.lfa to watch two sample solutions.

TIP: 2/4, 3/4, and 4/4 time signatures are examples of simple time; the corresponding
frame rate should be even, that is multiples of two.

6/8, 9/8, and 12/8 are examples of compound time; the corresponding frame rate should
be multiples of three (triplets).

Simple time signatures give an even, regular feel whereas compound time signatures
give an uneven, lilting feel.

                                                
18 You may need to use an underscore (“_”) if your Win OS does not allow you to use a forward slash (“/”).
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4. Now let’s set the enchaînement to a 6/8 rhythm. As dancers, we may count one bar of
6/8: “1, 2, 3, 4, 5, 6.” Or, since this rhythm is grouped as two triplets (with a strong
accent on “1” and a weak accent on “4”), we may say “1, &, a, 2, &, a.”19

To start, close any open files, then open Exercise16.lfa and Save As… under your own
name (e.g., MyExercise16Allegro6/8.lfa). Let’s set the enchaînement to two bars of 6/8,
with two jumps per bar, each landing on an accented count.
4.1 First, label each landing position as shown below:

4.2 Then change the frame rate to 18 fps and centre the triangle in the PANEL.
4.3 Add new frames to make each jump take 12 frames, i.e., 3/4 second.
TIP: Where you add new frames will change the quality of the jump (see below).
Next, select a sound file with a fast tempo (Sound menu > Sound File… Choose >
4bps240bpm.aif – a metronome beat every 3/4 second, corresponding to each landing.
4.4 We’ll count six very quick metronome beats per bar, or 3 beats (a triplet) per jump
(“1, &, a, 2, &, a”). Watch the animation to see how the sound and movement
correspond. We need to fine-tune it.
4.5 Make Rose hold the starting position as an introduction to the enchaînement: Copy
the starting position, Paste it beside the first frame, and add new frames in between to
show the dancer holding 5th position for one bar before the preparatory plié.
4.6 To suggest an accent up (more time in air) add new frames in the aerial phase, e.g.:

4.7 To suggest an accent down (more time on landing) add new frames before the
demi-plié (remember to add or delete frames to a total of 12 frames per jump), e.g.:

4.8 To watch some sample solutions, open:
Exercise16aExample6/8.lfa (danced to six metronome beats per bar: 4 bps)
Exercise16bExample6/8.lfa (danced to two metronome beats per bar: 1.5 bps)

                                                
19 Since the “&” count is not really halfway, it is better to say something like: “1, u, da, 2, u, da.”
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The charts below summarize ways of timing your enchaînements to metronome files
provided in DanceForms. But anything goes! Just experiment until you get what you want.

Remember to start with the lowest frame rate needed to describe the movement. In general,
the slower the movement, the lower the frame rate. Lower frame rates produce shorter
scores that are easier to navigate and edit.

On the other hand, to create subtle differentiation in timing, you need a higher frame rate.
You can try creating jumps in allegro tempi, taking from half to a full second each:

TYPE TEMPO 1 JUMP
TAKES
(sec)

frames
@ 12 fps

frames
@ 24 fps

petit allegro presto 1/2-2/3 6-8 12-16
medium
allegro

allegretto 2/3-3/4 8-9 16-18

grand allegro allegro 3/4-1 10-12 19-24

Time
Signature

Sample
Frame Rate
of Dance (fps)

Sound file
Metronome
(bps/bpm)

Metronome
Beats per

Bar of Music

Frames per
Bar of
Dance

2/4 12 1/60 2 24
3/4 12 1/60 3 36
4/4 12 1/60 4 48*
6/8 18 1.5/90 2 48**
9/8 18 1.5/90 3 72
12/8 18 1.5/90 4 96

*See TimingTest1.lfa. **See TimingTest2.lfa.

Once you finish a SCORE it is difficult to decrease the frame rate, but you can always
increase the frame rate to fine-tune your composition.

TIP: To increase the frame rate without changing the duration of your SCORE:
1. Click in the SCORE window in the area containing the dancer’s name: the entire

SCORE for that dancer is selected (surrounded by a coloured rectangle).
2. Select Edit menu > Copy.
3. Select Control menu > Frame Rate…, enter a new number, then click OK.
4. Without deselecting the SCORE for the dancer, select Edit Menu > Paste (first select

Edit menu > Paste Defaults, and set √Absolute Location, √Absolute Facing).
DanceForms automatically redistributes your keyframes to preserve the timing.

Consider, for example, changing the frame rate of a 30-frame sequence from 3 fps to 6 fps
as described above. When you Paste the original sequence, DanceForms will double the
total number of frames, distributing 30 frames across 60 frames. Since the frame rate has
also doubled (twice as fast) the total duration of the sequence is unchanged. You can now
change empty frames into keyframes and edit them to refine your movements, or shift
frames slightly in the SCORE to vary the timing.
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Exercise 17. Adjusting Paths Across the Floor:
Learning Other Dancers’ Steps and Adding More Dancers

17.1 You can alter the line of travel of an enchaînement or combination to make a variety
of straight, angular or curved paths across the floor. You can have different dancers
perform your combinations, and add more dancers to create group work and floor patterns.

In this Exercise we look at a basic triplet forward, and learn how to change its location on
the stage, as well as the angle, direction and shape of the path.
Exercise 17 brings together all of the techniques introduced in this Guide, so you may need
to refer back often. To share questions, post them on the DanceForms Subscriber List.20

17.2 To get started, open JacquesWaiting.lfa and Save As… under your own name, e.g.,
MyExercise17.lfa. Open the Dictionary file “Triplets” and watch Resa perform some triplet
variations. Select and Copy the version you prefer (start with a simple sequence and be sure
to make the first and last frames keyframes before you Copy it), then close the file.
Select the Paste Defaults you want, then Paste the copied frames into your SCORE. Since
Jacques will perform Resa’s triplets from the Dictionary, a Joint Map editor window
appears. Just click “Guess By Name”, then click OK, and Jacques will “learn” the
movements created for Resa. Set the frame rate at 6 fps and select the 3bps180bpm.aif
sound file to beat a quick 3/4 tempo. Watch Jacques do two triplets travelling toward the
audience. Add new frames after his Waiting Position to make Jacques wait for 2 bars and
synchronize the triplets with the metronome beats (see below). Type some helpful labels.

1. To extend the straight path, we need to add more triplets: Select and Copy the two-
triplet phrase (6 frames per triplet, then Paste it after the second triplet.
Watch Jacques do four triplets.

TIP: In the Dictionary triplet, each frame was Snapped to the previous. When Snap is
correctly set, Pasted frames automatically continue the line of travel (you may need to
select the Pasted frames in the SCORE then select Snap menu > Resnap).
When Snap has not been set and you want to continue the line of travel, you need to set
Paste Defaults (√Relative Path √Relative Direction or √Match Path Direction) prior to
Pasting the frames (see Exercise 11).

                                                
20 To join the DanceForms Subscribers List, a free service, go to http://list.web.ca/lists/listinfo/danceforms-l.
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2. To change the location of the path, there are a few simple techniques.

2.1 First, let’s watch the phrase in the STAGE from the Top view.

SHORTCUT: +L, +2 (Mac) Ctrl+L, Ctrl+2 (Win). To see the path, press the
+K (Mac) Ctrl+K (Win) key command (see Exercise 6). Now, select the four-triplet

phrase and the SCORE and note that the line of travel becomes vivid on the STAGE.

TIP 1: To select the entire sequence of frames in the SCORE, place your cursor to the
left of the SCORE (in the area containing the dancer’s name) and click. A rectangular
bounding box now surrounds all frames.

2.2 To move the entire path in the STAGE window, place your cursor on one of the
small rectangular nodes on the path, and drag the path to a new location. If you want to
return to the original location select Edit Menu > Undo.

TIP 2: There is a simple way to move a path when Snap has been correctly set. Just
drag the starting location to a new place on stage, then select the entire triplet sequence
in the SCORE (see TIP 1) and select Snap menu > Resnap.

TIP 3: To move the dancer to a precise starting location, type values directly into the
two boxes above his Figure Status grid (beside the  icon), then Resnap the sequence.

3. To change the angle of the path, you just change the dancer’s facing at the start and
end of the path (making sure that there are no unwanted facing angles set in between).
TIP: To remove unwanted keyframes for facing angles, select the frame or frames
containing them, then select Edit menu > Clear > Facing).
SHORTCUT: Ctrl+F (Mac) Ctrl+Alt+F (Win)

There are several ways to do this (see Exercise 4).
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3.1 You can click above the starting position to make that frame active, then select the
entire sequence in the SCORE. Next, click on the STAGE window title bar to activate
that window: it looks like the illustration above, except that the path is vivid. Move
your cursor directly to one of the rotation arrows  and hold down the mouse
button: the entire path rotates clockwise  or counter-clockwise  until you release
the button.

3.2 You can specify a facing angle for the start and end of the triplet in the STAGE
window (type a new value beside the  icon), then select the entire sequence in the
SCORE and select Snap menu > Resnap.

4. To change the direction of the path, simply set new facings.

To retain a facing so that the dancer moves along a straight line, reset the same facing
angle at the start and end of a sequence.

TIP: Be sure to check that no unwanted facing angles are set in between.

To change facings so that the dancer moves in a new direction, set a new angle.

TIP: To change direction abruptly, set a new facing angle in the very next frame, i.e.,
a) and b) below.

To change gradually set a new angle several frames later, i.e., c) and d) below.

For example, try to create a) a zig-zag path, or b) a box pattern:

 
a) b)

a) zig-zag

1. Set the dancer’s facing angle at the start and end of the 4-triplet sequence to 45°.
2. Remove unwanted facing angles in between, then select the sequence and Resnap.
3. Play the animation and watch the dancer move toward downstage right.
4. Decide where to change his facing angle to move each triplet toward alternate
corners – downstage right (45°), downstage left (315°), downstage right (45°), etc.):
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b) box
1. Set the dancer’s facing angle at the start and end of the 4-triplet sequence to 0°.
2. Remove unwanted facing angles in between, then select the sequence and Resnap.
3. Play the animation and watch the dancer move downstage.
4. Decide where to change his facing to move each triplet in series toward the audience
(0°), stage left (270°), upstage (180°), and stage right (90°):

5. To change the shape of the path from straight to curved, you need to change the
dancer’s facing gradually.
Try to create c) a circular path, or d) an “S” pattern (start these centre stage, 0.00, 0.00):

c) d)
c) circular path
1. Set the dancer’s facing angle at the start and end of the 4-triplet sequence to 0°.
2. Remove unwanted facing angles in between, then select the sequence and Resnap.
3. Play the animation and watch the dancer move downstage.
4. Decide where to change his facing angle to gradually complete a 360° circle
clockwise over the 4-triplet sequence (a smooth 90° change over each 6-frame triplet):
TIP: Always change the dancer’s facing angle in increments of less than 180°.

d) “S” pattern
1. Set the dancer’s facing angle at the start and end of the 4-triplet sequence to 0°.
2. Remove unwanted facing angles in between, then select the sequence and Resnap.
3. Play the animation and watch the dancer move downstage.
4. Decide where to change his facing angle to complete a half-circle counter-clockwise
on the first 2 triplets, then a half-circle clockwise on the last 2 triplets:

To watch one set of solutions to these, open Exercise17Example.lfa.
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6. Finally, let’s have different dancers perform the triplet sequence, and add more dancers
to create group work and floor patterns. You can Copy any set of triplets from your
personal file, from Exercise17Example.lfa, or the Dictionary into a new file and “teach”
each sequence to a new dancer.

6.1 To start, Copy the sequence you want to use (first be sure to set the start and end
frames in the sequence as Edit menu > Key Frame > All). Close the file from which
you Copied the sequence and open a new file (File menu > New animation). Then click
in the STAGE window to activate it, and Paste the sequence (first set Paste Defaults as
needed). DanceForms adds the dancer from the source file into this new file. If the
frame rate differs, a dialogue box will ask you if you want to “Change the frame rate to
match the source.” Click the Change Frame Rate button and your animation will be
expanded or compressed as needed.

6.2 Create a long triplet sequence travelling across the stage, using any of the
techniques introduced in this Exercise.

6.3 To add another Male Modern dancer who looks like Jacques, just copy Jacques’s
sequence from the current SCORE or any other, click on the STAGE window to
activate it and Paste the sequence (make sure the original Jacques is not selected,
otherwise the frames will be Pasted into his SCORE). A new Jacques appears on the
STAGE.

TIP: If Paste Defaults were set to √Absolute Location √Absolute Facing, the new
Jacques will be superimposed on the original dancer. Click on the dancer in the STAGE
window and note that two Figure Status grids appear for dancers named “J”. If you like,
you can select one dancer and rename him: select the dancer (click on his identification
in the Figure Status Grid), then select Figure menu > Name… and type a new name.
You can change one dancer’s location and facing, then ReSnap him to set his new path.

6.4 To add a different dancer, select Figure menu > New Figure > Female Ballet
(Rose), Female Modern (Resa), Male Ballet (Ben), etc. When you Copy Jacques’s
sequence from his line in the SCORE window and Paste it onto a new dancer’s line in
the SCORE window, the Joint Map Editor appears (as described earlier in this
Exercise). Just click “Guess By Name”, then click OK. The new dancer “learns” the
original sequence. Now, you can make any adjustments you like to his or her positions
or movements, using the range of techniques presented in PARTS A-C of this User
Guide, or in the DanceForms 1.0 Reference Guide.

6.5 For example, use the Mirror feature (see Exercise 13) to produce crossing paths.

6.6 Try adding a metronome beat (see Lesson 16), then add new frames to the SCORE
at the start of a sequence for each dancer, to offset the timing and create a canon effect.

To watch variations on a triplet pattern performed by a four-dancer ensemble, open
Lesson17TripletStudy.lfa.

To share other solutions, post them on DanceForms Subscriber List, a free service.
To subscribe, go to http://list.web.ca/lists/listinfo/danceforms-l.
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Pelvis red -X bend
forward

+X bend back -Y turn L +Y turn R -Z tilt L +Z tilt R

Head orange -10/15 flexion 10/15
hyperextension

-12.5
rotation L

12.5
rotation R

-8 lateral
flexion L

8 lateral
flexion R

Neck orange -80 flexion 50/60
hyperextension

-80
rotation L

80
rotation R

-25/-35 lateral
flexion L

25/-35 lateral
flexion R

RShoulder green -10 forward
rotation

10 backward
rotation

-10
protraction

12
retraction

-25
elevation

1
depression

RUpperArm red -60
hyperextension

180
flexion

-55 medial
rotation

50 lateral
rotation

-180
abduction

50
adduction

RLowerArm yellow -5/10
hyperextension

160 flexion na na na na

RHand blue -15 ulnar
flexion

45-55 radial
flexion

na [cf ulnar
rotation]

na [cf radial
rotation]

-85
dorsiflexion

85 palmar
flexion

RFingers assorted -20
adduction (1)

20
abduction (1)

na na -90 hyper-
extension

90+
flexion

RThumb blue, etc. slight
adduction (1)

40/50
abduction(1)

na na slight
hyperextension

50/90
flexion

LShoulder fuchsia -10 forward
rotation

10 backward
rotation

-12 retraction 10 protraction -1
depression

25
elevation

LUpperArm green -60
hyperextension

180
flexion

-50 lateral
rotation

55 medial
rotation

-50
adduction

180
abduction

LLowerArm red -5/10
hyperextension

160
flexion

na na na na

LHand yellow 15 ulnar
flexion

-45-55
radialflexion

na [cf radial
rotation]

na [cf ulnar
rotation]

-85 palmar
flexion

85 dorsiflexion

LFingers assorted -20
adduction(1)

20
abduction(1)

na na -90+
palmar flexion

90
dorsiflexion

LThumb green, etc. slight
adduction (1)

40/50
abduction(1)

na na -50/90
flexion

slight
hyperextension

Upper Chest ochre -40 flexion 20
hyperextension

-15
rotation L

15
rotation R

-10 lateral
flexion L

10 lateral
flexion R

Chest aqua -65 flexion 40
hyperextension

-20
rotation L

20
rotation R

-10 lateral
flexion L

10 lateral
flexion R

Waist periwinkle -60
flexion

35
hyperextension

-5
rotation L

5
rotation R

-20 lateral
flexion L

20 lateral
flexion R

RUpperLeg red -30
hyperextension

130 flexion -45 medial
rotation

55 lateral
rotation

-55
abduction

45
adduction

RLowerLeg yellow -135
flexion

15
hyperextension

slight with
flexion

slight with
flexion

slight with
flexion

slight with
flexion

RFoot blue -20/30+
plantar flexion

30-50
dorsiflexion

-22.5
adduction

22.5 abduction -25/30
eversion

50
inversion

RArch pink slight
plantarflexion

slight
dorsiflexion

slight
adduction

slight
abduction

slight
eversion

slight
inversion

RToes purple-pink -100
plantarflexion

125
dorsiflexion

slight
adduction

slight
abduction

na na

LUpperLeg red -30
hyperextension

130
flexion

-55 lateral
rotation

45 medial
rotation

-45
adduction

55
abduction

LLowerLeg green -135
flexion

15
hyperextension

slight with
flexion

slight with
flexion

slight with
flexion

slight with
flexion

LFoot periwinkle -20/30+
plantar flexion

30-50
dorsiflexion

-22.5
abduction

22.5
adduction

-50
inversion

25/30
eversion

LArch green slight
plantarflexion

slight
dorsiflexion

slight
abduction

slight
adduction

slight
inversion

slight
eversion

LToes ochre -100
plantarflexion

125
dorsiflexion

slight
abduction

slight
adduction

na na
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These animations and palettes illustrate concepts introduced in each Exercise.
Notice the extensions: “.lfa” to show a DanceForms animation

“.lfp” to show a DanceForms palette
“.aif” to show a sound file

EXERCISE ANIMATION (.lfa) PALETTE (.lfp) or SOUND FILE

PART A: Entering the DanceFormsWorld
Exercise 1 Exercise1.lfa

Exercise 2 Exercise2.lfa
Exercise2Example1.lfa
Exercise2Example2.lfa

Exercise2.lfp

Exercise 3 Exercise3.lfa
Exercise3Example1.lfa
Exercise3Example2.lfa

Exercise3.lfp
2bps120bpm.aif

Exercise 4 Exercise4.lfa
Exercise4PirouetteExample.lfa
Exercise4SpiralExample.lfa

Exercise4.lfp

Exercise 5 Exercise5.lfa
Exercise5Example.lfa

Exercise5.lfp

Exercise 6 Exercise6.lfa
Exercise6Example.lfa

Exercise6.lfp

PART B: Working in the DanceFormsSTUDIO
Exercise 7 Exercise7BasicMovements.lfa

Exercise7TheStudio.lfa

Exercise 8 Exercise8.lfa

Exercise 9 Exercise9.lfa
Exercise9CombinedPositions.lfa
Exercise9TweenedPositions.lfa

Exercise 10 Exercise10.lfa Exercise10.lfp

PART C: Creating with Ballet Moves and Modern Dance Moves
Exercise 11 BasicPositions.lfp

Exercise 12 RoseWaiting.lfa
Soubresaut.lfa
Changement.lfa
Exercise12Example.lfa

Exercise 13 Exercise13Example.lfa

Exercise 14 Exercise14Example.lfa

Exercise 15 BasicPortdeBras.lfa
Exercise15Example1.lfa
Exercise15Example2.lfa

Exercise 16 Exercise16.lfa
Exercise16Example.lfa
Exercise16Example2/4.lfa
Exercise16aExample6/8.lfa
Exercise16bExample6/8.lfa
TimingTest1.lfa
TimingTest2.lfa

1bps60bpm.aif
1.5bps90bpm.aif
4bps240bpm.aif
1bps60bpm.aif
1.5bps90bpm.aif

Exercise 17 Triplets.lfa
Exercise17Example.lfa
TripletStudy1.lfa
TripletStudy2.lfa

3bps180bpm.aif
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Ballet Moves Animations:

English Dictionary:

............................
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English Dictionary (continued):

 .......................
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Russian Dictionary:

 ................
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Russian Dictionary (continued):

.................  

Italian Dictionary:
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Ballet Moves Palettes:

English Dictionary: Russian Dictionary: Italian Dictionary:

Ballet Moves Sound Files:

2-minute duration of metronome beats:

4-minute duration of metronome beats (long and slow for Adage enchaînements):
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Modern Dance Moves Animations

Floorwork: Centrework:

 

Note:  is located in the Floorwork folder but contains transitions in
sitting and kneeling positions as well as transitions from the floor to standing and reverse.

Modern Dance Palettes:

Modern Dance Sound Files: see Ballet Moves Sound files
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Please note:
On Two Button Mice,
Shift Right Click = Middle Mouse Button MB=Mouse Button

LMB=
   Left Mouse Button
MMB=
  Middle Mouse Button
RMB=
   Right Mouse Button

Mac Win
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Selections
Select All figures in Stage, All joints in STUDIO Cmnd A Ctrl A
Select All Frames in SCORE Cmnd [ Alt [
Fit selected joint to view (STUDIO Only) S S
Fit entire stage to view (STAGE Only) D D
Fit Figure to view A A

Navigation
Frames
Back Step Left arrow

(Also Cmnd-B)

Left arrow

Forward Step Right arrow

(Also Cmnd-F)

Right arrow

Return to first frame Home Home
Go to last frame End End
Open the Goto dialog box Cmnd G Ctrl G
Select Pasted Frames Cmnd J Ctrl J
Views
Display Front view F

(Also Cmnd-1)

F

(Also Ctrl-1)
Display Top view T T
Display Right view R R
Display Left view L L
Zoom in (fine-tuning) Z Z
Zoom out (fine-tuning) X X
Mouse Controls for View
Pan view MB LMB
Zoom view Cmnd + MB RMB
Rotate view Option MB MMB
Other View Navigation keys
Tilt the foreground of the STAGE down V V
Tilt the foreground of the STAGE up C C
Rotate the STAGE to your right B B
Rotate the STAGE to your left N N
Pan up M M
Pan down ? ?
Pan to the Right > >
Pan to the Left < <
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On Two Button Mice,
Shift Right Click = Middle Mouse Button MB=Mouse Button

LMB=
   Left Mouse Button
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  Middle Mouse Button
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   Right Mouse Button

Mac Win
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Windows
Open or make STUDIO active Cmnd E Ctrl E
Open or make STAGE window active Cmnd L Ctrl L
Open or make SCORE window active Cmnd T Ctrl T
Open or make PERFORMANCE window active Cmnd R Ctrl R
Open File Browser Ctrl O Ctrl F
Open or make Joint Material window active for
Selected Joint

Option + Cmnd J

Open or make Panel window active Option + Cmnd P

Display
Display or hide paths of Selected Figures Cmnd K Ctrl K
Toggle Always Display Path of All Figures Option + Cmnd K
Display selected figures in Sticks Style Cmnd 5 Ctrl 5
Display selected figures in Bounding Box S Cmnd 6 Ctrl 6
Display selected figures in Contours Cmnd 7 Ctrl 7
Display selected figures in Outline Cmnd 8 Ctrl 8
Display selected figures in Surfaces Cmnd 9 Ctrl 9

Operations
Stop Playback ESC ESC
Playback Tilde Tilde
Copy Cmnd C Ctrl C
Paste Cmnd V Ctrl V
Paste Special Option + Cmnd V
Insert Blank Frame Space bar Space bar
Import Figure Cmnd I
Remove Selected Figure Option + Cmnd F
Mirror selected joints Cmnd M Ctrl M
Undo Cmnd Z Ctrl Z
Playback selected figures Cmnd Y Ctrl Y
Playback in whole screen (toggle) Cmnd U Ctrl U
Print Ctrl P
Open Walk Generator Cmnd ] Alt ]
Keyframe all attributes in current keyframe Cmnd ` (part of tilde key) Alt ` (part of tilde key)
Reset to default shape Cmnd / Alt /
Revert Cmnd - Alt - (keypad)
Add to Palette Cmnd = Alt =
Mouse Controls for Rotating Joints
Rotate around X axis Ctrl + MB Ctrl + LMB
Rotate around Z axis Ctrl + Option + MB Ctrl + RMB
Rotate around Y axis Ctrl + Cmnd + MB Ctrl + MMB



Appendix E. DanceForms Shortcuts

Key Shortcuts

Please note:
On Two Button Mice,
Shift Right Click = Middle Mouse Button MB=Mouse Button

LMB=
   Left Mouse Button
MMB=
  Middle Mouse Button
RMB=
   Right Mouse Button

Mac Win

85

Workspace Management
Arrange windows Cmnd D Ctrl D
Hide all but top window Cmnd ; Alt ;
Bring next animation's windows to front Option + Tab Ctrl + Q
Make next window active Ctrl + Tab Ctrl + Tab

Snap
Resnap Shift + Cmnd + R Alt + Shift + R
Snap Same as Previous Shift + Cmnd + P Alt + Shift + P
Position Same as Next Shift + Cmnd + N Alt + Shift + N
Snap Shift + Cmnd + S Alt + Shift + S
Auto Snap Shift + Cmnd + A Alt + Shift + A
Clear Snap Shift + Cmnd + C Alt + Shift + C
Snap Altitude Shift + Cmnd + T Alt + Shift + T
Snap Location Shift + Cmnd + L Alt + Shift + L
Keyframes Only Shift + Cmnd + K Alt + Shift + K
Adjust Following Frames Shift + Cmnd + F Alt + Shift + F
Left Toe Tip Ctrl + Cmnd + T Ctrl + Shift + T
Right Toe Tip Option + Cmnd + T Ctrl + Alt + T
Left Toe Ctrl + Cmnd + B Ctrl + Shift + B
Right Toe Option + Cmnd + B Ctrl + Alt + B
Left Heel
Right Heel
Left Fingers Ctrl + Cmnd + H Ctrl + Shift + H
Right Fingers Option + Cmnd + H Ctrl + Alt + H

File
Open Cmnd O Ctrl O
Save Cmnd S Ctrl S
Save All Option + Cmnd S
Close Cmnd W Ctrl W
Close All Option + Cmnd W
New file Cmnd N Ctrl N
Export Option + Cmnd E

Application
Exit Cmnd Q Alt F4


